summaryrefslogtreecommitdiff
path: root/numpy/distutils/command/build_ext.py
diff options
context:
space:
mode:
authorCharles Harris <charlesr.harris@gmail.com>2011-08-20 11:13:08 -0600
committerCharles Harris <charlesr.harris@gmail.com>2011-08-20 11:13:08 -0600
commitea529d4081a38acf85a759dda25e3edf0bd307dc (patch)
treeb42da1d4d06352757b30d7001b34d5b790f36563 /numpy/distutils/command/build_ext.py
parentcdf1ff1d2f92582d5aa150573a056462341d2dcf (diff)
downloadnumpy-ea529d4081a38acf85a759dda25e3edf0bd307dc.tar.gz
BUG: Revert commit that causes many tests not to run.
Revert "Introduce new options extra_f77_compiler_args and extra_f90_compiler_args to Configuration.add_extension. Configuration.add_library, and Extension. These options allow specifying extra compile options for compiling Fortran sources within a setup.py file." This reverts commit 43862759384a86cb4a95e8adb4d39fa1522acb28.
Diffstat (limited to 'numpy/distutils/command/build_ext.py')
-rw-r--r--numpy/distutils/command/build_ext.py3
1 files changed, 0 insertions, 3 deletions
diff --git a/numpy/distutils/command/build_ext.py b/numpy/distutils/command/build_ext.py
index f63d5249c..840d43716 100644
--- a/numpy/distutils/command/build_ext.py
+++ b/numpy/distutils/command/build_ext.py
@@ -299,9 +299,6 @@ class build_ext (old_build_ext):
fcompiler = self._f77_compiler
else: # in case ext.language is c++, for instance
fcompiler = self._f90_compiler or self._f77_compiler
- if fcompiler is not None:
- fcompiler.extra_f77_compile_args = ext.extra_f77_compile_args or []
- fcompiler.extra_f90_compile_args = ext.extra_f90_compile_args or []
cxx_compiler = self._cxx_compiler
# check for the availability of required compilers