summaryrefslogtreecommitdiff
path: root/numpy/matrixlib/tests/test_numeric.py
diff options
context:
space:
mode:
authorCharles Harris <charlesr.harris@gmail.com>2013-03-27 21:49:08 -0600
committerCharles Harris <charlesr.harris@gmail.com>2013-03-28 08:43:26 -0600
commitd4b88c1dbd6898fb6fcebc97f36b421999340f71 (patch)
tree61cc0282cf2509afe364c91e97b59dfb2ebcafd3 /numpy/matrixlib/tests/test_numeric.py
parent40742184df68fc01f3392c9865f35d5402e74b01 (diff)
downloadnumpy-d4b88c1dbd6898fb6fcebc97f36b421999340f71.tar.gz
2to3: Use absolute imports.
The new import `absolute_import` is added the `from __future__ import` statement and The 2to3 `import` fixer is run to make the imports compatible. There are several things that need to be dealt with to make this work. 1) Files meant to be run as scripts run in a different environment than files imported as part of a package, and so changes to those files need to be skipped. The affected script files are: * all setup.py files * numpy/core/code_generators/generate_umath.py * numpy/core/code_generators/generate_numpy_api.py * numpy/core/code_generators/generate_ufunc_api.py 2) Some imported modules are not available as they are created during the build process and consequently 2to3 is unable to handle them correctly. Files that import those modules need a bit of extra work. The affected files are: * core/__init__.py, * core/numeric.py, * core/_internal.py, * core/arrayprint.py, * core/fromnumeric.py, * numpy/__init__.py, * lib/npyio.py, * lib/function_base.py, * fft/fftpack.py, * random/__init__.py Closes #3172
Diffstat (limited to 'numpy/matrixlib/tests/test_numeric.py')
-rw-r--r--numpy/matrixlib/tests/test_numeric.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/numpy/matrixlib/tests/test_numeric.py b/numpy/matrixlib/tests/test_numeric.py
index 5539dac0d..7b690fbef 100644
--- a/numpy/matrixlib/tests/test_numeric.py
+++ b/numpy/matrixlib/tests/test_numeric.py
@@ -1,4 +1,4 @@
-from __future__ import division
+from __future__ import division, absolute_import
from numpy.testing import assert_equal, TestCase
from numpy.core import ones