summaryrefslogtreecommitdiff
path: root/numpy/testing/utils.py
diff options
context:
space:
mode:
authorCharles Harris <charlesr.harris@gmail.com>2013-03-27 21:49:08 -0600
committerCharles Harris <charlesr.harris@gmail.com>2013-03-28 08:43:26 -0600
commitd4b88c1dbd6898fb6fcebc97f36b421999340f71 (patch)
tree61cc0282cf2509afe364c91e97b59dfb2ebcafd3 /numpy/testing/utils.py
parent40742184df68fc01f3392c9865f35d5402e74b01 (diff)
downloadnumpy-d4b88c1dbd6898fb6fcebc97f36b421999340f71.tar.gz
2to3: Use absolute imports.
The new import `absolute_import` is added the `from __future__ import` statement and The 2to3 `import` fixer is run to make the imports compatible. There are several things that need to be dealt with to make this work. 1) Files meant to be run as scripts run in a different environment than files imported as part of a package, and so changes to those files need to be skipped. The affected script files are: * all setup.py files * numpy/core/code_generators/generate_umath.py * numpy/core/code_generators/generate_numpy_api.py * numpy/core/code_generators/generate_ufunc_api.py 2) Some imported modules are not available as they are created during the build process and consequently 2to3 is unable to handle them correctly. Files that import those modules need a bit of extra work. The affected files are: * core/__init__.py, * core/numeric.py, * core/_internal.py, * core/arrayprint.py, * core/fromnumeric.py, * numpy/__init__.py, * lib/npyio.py, * lib/function_base.py, * fft/fftpack.py, * random/__init__.py Closes #3172
Diffstat (limited to 'numpy/testing/utils.py')
-rw-r--r--numpy/testing/utils.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/numpy/testing/utils.py b/numpy/testing/utils.py
index 019adeb27..c08dd0c33 100644
--- a/numpy/testing/utils.py
+++ b/numpy/testing/utils.py
@@ -2,7 +2,7 @@
Utility function to facilitate testing.
"""
-from __future__ import division
+from __future__ import division, absolute_import
import os
import sys
@@ -10,7 +10,7 @@ import re
import operator
import types
import warnings
-from nosetester import import_nose
+from .nosetester import import_nose
__all__ = ['assert_equal', 'assert_almost_equal','assert_approx_equal',
'assert_array_equal', 'assert_array_less', 'assert_string_equal',