summaryrefslogtreecommitdiff
path: root/pavement.py
diff options
context:
space:
mode:
authorCharles Harris <charlesr.harris@gmail.com>2016-11-05 13:48:30 -0600
committerCharles Harris <charlesr.harris@gmail.com>2016-11-05 13:48:30 -0600
commitb33a5ee781bb4a775e5ccef1fdf88b61339becba (patch)
tree8bae05ba3681e1ce0cc8420f438226683f3963ab /pavement.py
parent674e61fbb359dea2f289d0621884a299774ef9ca (diff)
downloadnumpy-b33a5ee781bb4a775e5ccef1fdf88b61339becba.tar.gz
MAINT: Update pavement.py and setup.py for numpy 1.13.0.
Diffstat (limited to 'pavement.py')
-rw-r--r--pavement.py13
1 files changed, 2 insertions, 11 deletions
diff --git a/pavement.py b/pavement.py
index 0940d7159..a6072a997 100644
--- a/pavement.py
+++ b/pavement.py
@@ -99,10 +99,10 @@ finally:
#-----------------------------------
# Source of the release notes
-RELEASE_NOTES = 'doc/release/1.12.0-notes.rst'
+RELEASE_NOTES = 'doc/release/1.13.0-notes.rst'
# Start/end of the log (from git)
-LOG_START = 'maintenance/1.11.x'
+LOG_START = 'maintenance/1.12.x'
LOG_END = 'master'
@@ -150,10 +150,7 @@ SITECFG = {"sse2" : SSE2_CFG, "sse3" : SSE3_CFG, "nosse" : NOSSE_CFG}
if sys.platform =="darwin":
WINDOWS_PYTHON = {
"3.4": ["wine", os.environ['HOME'] + "/.wine/drive_c/Python34/python.exe"],
- "3.3": ["wine", os.environ['HOME'] + "/.wine/drive_c/Python33/python.exe"],
- "3.2": ["wine", os.environ['HOME'] + "/.wine/drive_c/Python32/python.exe"],
"2.7": ["wine", os.environ['HOME'] + "/.wine/drive_c/Python27/python.exe"],
- "2.6": ["wine", os.environ['HOME'] + "/.wine/drive_c/Python26/python.exe"],
}
WINDOWS_ENV = os.environ
WINDOWS_ENV["DYLD_FALLBACK_LIBRARY_PATH"] = "/usr/X11/lib:/usr/lib"
@@ -161,10 +158,7 @@ if sys.platform =="darwin":
elif sys.platform == "win32":
WINDOWS_PYTHON = {
"3.4": ["C:\Python34\python.exe"],
- "3.3": ["C:\Python33\python.exe"],
- "3.2": ["C:\Python32\python.exe"],
"2.7": ["C:\Python27\python.exe"],
- "2.6": ["C:\Python26\python.exe"],
}
# XXX: find out which env variable is necessary to avoid the pb with python
# 2.6 and random module when importing tempfile
@@ -173,10 +167,7 @@ elif sys.platform == "win32":
else:
WINDOWS_PYTHON = {
"3.4": ["wine", os.environ['HOME'] + "/.wine/drive_c/Python34/python.exe"],
- "3.3": ["wine", os.environ['HOME'] + "/.wine/drive_c/Python33/python.exe"],
- "3.2": ["wine", os.environ['HOME'] + "/.wine/drive_c/Python32/python.exe"],
"2.7": ["wine", os.environ['HOME'] + "/.wine/drive_c/Python27/python.exe"],
- "2.6": ["wine", os.environ['HOME'] + "/.wine/drive_c/Python26/python.exe"],
}
WINDOWS_ENV = os.environ
MAKENSIS = ["wine", "makensis"]