summaryrefslogtreecommitdiff
path: root/pavement.py
diff options
context:
space:
mode:
authorCharles Harris <charlesr.harris@gmail.com>2018-12-07 14:16:26 -0700
committerCharles Harris <charlesr.harris@gmail.com>2018-12-08 08:02:07 -0700
commitbadf2901ea040aa89dbb3c19e53c6b1b692cb489 (patch)
treefbfa204a1e969fd5e2a6090cb1ee00f0ff8bf944 /pavement.py
parentf07a38da97a6a36eb12b203f6c1ffa4bf2b2cb87 (diff)
downloadnumpy-badf2901ea040aa89dbb3c19e53c6b1b692cb489.tar.gz
MAINT: Prepare master for 1.17.0 development.
- Create 1.17.0-notes - Update index.rst for new notes - Update pavement.py - Update setup.py - Remove Python 2.7 and 3.4 from CI testing. - Add `# cython: language_level=3` to `*.pxd`, `*.pyx` files. Note that this removes support for both Python2.7 and Python3.4 in setup.py.
Diffstat (limited to 'pavement.py')
-rw-r--r--pavement.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/pavement.py b/pavement.py
index f2c56883b..2a5225f71 100644
--- a/pavement.py
+++ b/pavement.py
@@ -42,13 +42,12 @@ from paver.easy import Bunch, options, task, sh
#-----------------------------------
# Path to the release notes
-RELEASE_NOTES = 'doc/release/1.16.0-notes.rst'
+RELEASE_NOTES = 'doc/release/1.17.0-notes.rst'
#-------------------------------------------------------
# Hardcoded build/install dirs, virtualenv options, etc.
#-------------------------------------------------------
-DEFAULT_PYTHON = "2.7"
# Where to put the release installers
options(installers=Bunch(releasedir="release",