summaryrefslogtreecommitdiff
path: root/runtests.py
diff options
context:
space:
mode:
authorRalf Gommers <ralf.gommers@gmail.com>2021-05-09 17:09:40 +0200
committerRalf Gommers <ralf.gommers@gmail.com>2021-05-09 17:09:40 +0200
commite372d06eb8b4cf8e156e2a5b177f5bf222b4584a (patch)
tree911a78a8743384b667fd701885c9ffdf7e62c412 /runtests.py
parente3583316cab5e71f2b361c32a3eee748905f40c5 (diff)
downloadnumpy-e372d06eb8b4cf8e156e2a5b177f5bf222b4584a.tar.gz
DOC: add an extra example in runtests.py help test
This was a little confusing in the sprint. To verify, look at the output of `python runtests.py --help` [ci skip]
Diffstat (limited to 'runtests.py')
-rwxr-xr-xruntests.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/runtests.py b/runtests.py
index ea16845e3..452ccbc64 100755
--- a/runtests.py
+++ b/runtests.py
@@ -8,7 +8,10 @@ Examples::
$ python runtests.py
$ python runtests.py -s {SAMPLE_SUBMODULE}
+ $ # Run a standalone test function:
$ python runtests.py -t {SAMPLE_TEST}
+ $ # Run a test defined as a method of a TestXXX class:
+ $ python runtests.py -t {SAMPLE_TEST2}
$ python runtests.py --ipython
$ python runtests.py --python somescript.py
$ python runtests.py --bench
@@ -43,6 +46,7 @@ Provide target branch name or `uncommitted` to check before committing:
PROJECT_MODULE = "numpy"
PROJECT_ROOT_FILES = ['numpy', 'LICENSE.txt', 'setup.py']
SAMPLE_TEST = "numpy/linalg/tests/test_linalg.py::test_byteorder_check"
+SAMPLE_TEST2 = "numpy/core/tests/test_memmap.py::TestMemmap::test_open_with_filename"
SAMPLE_SUBMODULE = "linalg"
EXTRA_PATH = ['/usr/lib/ccache', '/usr/lib/f90cache',