summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--numpy/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/numpy/meson.build b/numpy/meson.build
index 23bd83a04..1625197d5 100644
--- a/numpy/meson.build
+++ b/numpy/meson.build
@@ -10,6 +10,7 @@ endif
# Platform detection
is_windows = host_machine.system() == 'windows'
is_mingw = is_windows and cc.get_id() == 'gcc'
+is_msvc = is_windows and cc.get_id() == 'msvc'
if is_windows
# For mingw-w64, link statically against the UCRT.
@@ -29,6 +30,9 @@ if is_windows
endif
endif
endif
+if is_msvc
+ add_project_arguments('-DNDEBUG', language: ['c', 'cpp'])
+endif
# Enable UNIX large file support on 32-bit systems (64 bit off_t,
# lseek -> lseek64, etc.)