summaryrefslogtreecommitdiff
path: root/numpy/tests/test_scripts.py
diff options
context:
space:
mode:
Diffstat (limited to 'numpy/tests/test_scripts.py')
-rw-r--r--numpy/tests/test_scripts.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/numpy/tests/test_scripts.py b/numpy/tests/test_scripts.py
index 5aa8191bb..892c04eef 100644
--- a/numpy/tests/test_scripts.py
+++ b/numpy/tests/test_scripts.py
@@ -9,7 +9,7 @@ from os.path import join as pathjoin, isfile, dirname
import subprocess
import numpy as np
-from numpy.testing import assert_equal
+from numpy.testing import assert_equal, IS_WASM
is_inplace = isfile(pathjoin(dirname(np.__file__), '..', 'setup.py'))
@@ -41,6 +41,7 @@ def test_f2py(f2py_cmd):
assert_equal(stdout.strip(), np.__version__.encode('ascii'))
+@pytest.mark.skipif(IS_WASM, reason="Cannot start subprocess")
def test_pep338():
stdout = subprocess.check_output([sys.executable, '-mnumpy.f2py', '-v'])
assert_equal(stdout.strip(), np.__version__.encode('ascii'))