diff options
author | Michał Górny <mgorny@gentoo.org> | 2020-09-25 16:28:26 +0200 |
---|---|---|
committer | GitHub <noreply@github.com> | 2020-09-25 15:28:26 +0100 |
commit | f382936ce4d5ad937f03d01da425444bca35cadd (patch) | |
tree | e3a56bfdff41eb6f795977507b3fafc2f46f0f52 /setup.py | |
parent | 38fbf7cd49114a38f95ed3055ef1343320e8d1a5 (diff) | |
download | paste-git-f382936ce4d5ad937f03d01da425444bca35cadd.tar.gz |
Add an explicit dependency on setuptools for pkg_resources (#60)
Since Paste uses pkg_resources explicitly, it should have a runtime
dependency on setuptools. While this does not make any difference
to pip users right now, it helps packagers correctly determine
the dependencies, for packaging systems that can remove/skip build-time
dependencies.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 5 |
1 files changed, 4 insertions, 1 deletions
@@ -52,7 +52,10 @@ setup(name="Paste", exclude_directories=finddata.standard_exclude_directories + ('tests',)), namespace_packages=['paste'], zip_safe=False, - install_requires=['six>=1.4.0'], + install_requires=[ + 'setuptools', # pkg_resources + 'six>=1.4.0', + ], extras_require={ 'subprocess': [], 'hotshot': [], |