summaryrefslogtreecommitdiff
path: root/examples/using_cpp_libc.py
diff options
context:
space:
mode:
authorBen <Ben@ben-home>2012-02-03 06:24:55 +0200
committerBen <Ben@ben-home>2012-02-03 06:24:55 +0200
commitf86dea169a1568afd44ed3436e93b1718bac7ad1 (patch)
treed88fb11cb528502f50d2ce8db64d5af31b3e916c /examples/using_cpp_libc.py
parent5cd3fd6478d99b75cdfce8c205c3f06997d9cf1b (diff)
downloadpycparser-f86dea169a1568afd44ed3436e93b1718bac7ad1.tar.gz
1. make examples callable from root dir
2. improve error message displayed to the user when cpp is not found by parse_file
Diffstat (limited to 'examples/using_cpp_libc.py')
-rw-r--r--examples/using_cpp_libc.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/examples/using_cpp_libc.py b/examples/using_cpp_libc.py
index fa9e6a7..1c28c7a 100644
--- a/examples/using_cpp_libc.py
+++ b/examples/using_cpp_libc.py
@@ -13,7 +13,7 @@ import sys
# This is not required if you've installed pycparser into
# your site-packages/ with setup.py
#
-sys.path.insert(0, '..')
+sys.path.extend(['.', '..'])
# Portable cpp path for Windows and Linux/Unix
CPPPATH = '../utils/cpp.exe' if sys.platform == 'win32' else 'cpp'