diff options
author | Tushar Gohad <tushar.gohad@intel.com> | 2015-08-02 06:11:43 +0000 |
---|---|---|
committer | Tushar Gohad <tushar.gohad@intel.com> | 2015-08-02 06:12:04 +0000 |
commit | 1a9a3b18ff1274d417c3b365bb474daed5e27793 (patch) | |
tree | 65caefc25dbd0f123bf0a55f7a4fc490fbd44bbc /setup.py | |
parent | 0c1d3dfe6595fc45a214a15e2f97c0a74fb79a21 (diff) | |
download | pyeclib-libec_path.tar.gz |
Fix find_library() param to be just "erasurecode"libec_path
... or else setup.py is not able to located liberasurecode
although it is already installed
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 8 |
1 files changed, 4 insertions, 4 deletions
@@ -29,7 +29,7 @@ import platform import sys from ctypes import * -from ctypes.util import * +from ctypes.util import _findLib_gcc from distutils.command.build import build as _build from distutils.command.clean import clean as _clean from distutils.sysconfig import EXEC_PREFIX as _exec_prefix @@ -105,9 +105,6 @@ class build(_build): def check_liberasure(self): library_basename = "liberasurecode" library_version = "1.0.8" - notfound = True - found_path = _find_library(library_basename) - if platform_str.find("Darwin") > -1: liberasure_file = \ library_basename + "." + library_version + ".dylib" @@ -115,6 +112,9 @@ class build(_build): liberasure_file = \ library_basename + ".so." + library_version + notfound = True + found_path = _find_library("erasurecode") + if found_path: if found_path.endswith(library_version) or \ found_path.find(library_version + ".") > -1: |