summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDavid Pursehouse <david.pursehouse@sonymobile.com>2013-08-04 14:33:19 +0900
committerDavid Pursehouse <david.pursehouse@sonymobile.com>2013-08-05 19:18:11 +0900
commitbb44bf7c42a1797fc9a6d22c5be7ba3eff4b8744 (patch)
tree42d717ecab809d50aedee38f6b460ce431dce1aa /setup.py
parentee0a7001bf42c4fee00b480865bede265bffaf22 (diff)
downloadpygerrit-bb44bf7c42a1797fc9a6d22c5be7ba3eff4b8744.tar.gz
Don't hard code version in setup.py
We're currently only using the version number in the setup script, but in future we might need it in other places too. Define the version number in the module itself and import it in setup. Change-Id: Idbf246d3a9777f6de710cb01fa05f8fbf031d192
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 1fa5e69..dfa9f2d 100755
--- a/setup.py
+++ b/setup.py
@@ -26,10 +26,12 @@ THE SOFTWARE.
from setuptools import setup
+from pygerrit import __version__
+
setup(
name="pygerrit",
description="Client library for interacting with Gerrit",
- version="0.0.7",
+ version=__version__,
license="The MIT License",
author="David Pursehouse",
author_email="david.pursehouse@sonymobile.com",