diff options
-rw-r--r-- | CHANGES | 2 | ||||
-rw-r--r-- | pyproject.toml | 1 | ||||
-rw-r--r-- | tox.ini | 2 |
3 files changed, 4 insertions, 1 deletions
@@ -15,6 +15,8 @@ Version 3.2.0 will also discontinue support for Python versions 3.6 and 3.7. Version 3.1.0b1 - April, 2023 ----------------------------- +- Added support for Python 3.12. + - API CHANGE: A slight change has been implemented when unquoting a quoted string parsed using the QuotedString class. Formerly, when unquoting and processing whitespace markers such as \t and \n, these substitutions would occur first, and diff --git a/pyproject.toml b/pyproject.toml index 7d21f5e..d303a9a 100644 --- a/pyproject.toml +++ b/pyproject.toml @@ -23,6 +23,7 @@ classifiers = [ "Programming Language :: Python :: 3.9", "Programming Language :: Python :: 3.10", "Programming Language :: Python :: 3.11", + "Programming Language :: Python :: 3.12", "Programming Language :: Python :: 3 :: Only", "Programming Language :: Python :: Implementation :: CPython", "Programming Language :: Python :: Implementation :: PyPy", @@ -1,7 +1,7 @@ [tox] skip_missing_interpreters=true envlist = - py{36,37,38,39,310,311,py3},mypy-test + py{36,37,38,39,310,311,312,py3},mypy-test isolated_build = True [testenv] |