summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.travis.yml10
-rw-r--r--setup.py2
2 files changed, 4 insertions, 8 deletions
diff --git a/.travis.yml b/.travis.yml
index 694b6aa..2ff0fc0 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,16 +1,12 @@
language: python
-sudo: false
python:
- "2.7"
- - "3.4"
- "3.5"
- "3.6"
+ - "3.7"
+ - "3.8"
- "pypy"
-matrix:
- include:
- - python: "3.7"
- dist: xenial
- sudo: required
+ - "pypy3"
install:
- pip install -q "flake8"
script:
diff --git a/setup.py b/setup.py
index 4bee288..197757f 100644
--- a/setup.py
+++ b/setup.py
@@ -24,10 +24,10 @@ setup(
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Topic :: Software Development :: Libraries :: Python Modules',
],
)