summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 8 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index b8a0d79..d1e777a 100644
--- a/setup.py
+++ b/setup.py
@@ -11,12 +11,13 @@ setup(
version=version,
description="Pure python memcached client",
long_description=open("README.md").read(),
+ long_description_content_type="text/markdown",
author="Evan Martin",
author_email="martine@danga.com",
maintainer="Sean Reifschneider",
- maintainer_email="jafo@tummy.com",
+ maintainer_email="jafo00@gmail.com",
url="https://github.com/linsomniac/python-memcached",
- download_url=dl_url.format(version),
+ download_url="https://github.com/linsomniac/python-memcached/releases/download/{0}/python-memcached-{0}.tar.gz".format(version), # noqa
py_modules=["memcache"],
install_requires=open('requirements.txt').read().split(),
classifiers=[
@@ -28,11 +29,12 @@ setup(
"Topic :: Internet",
"Topic :: Software Development :: Libraries :: Python Modules",
"Programming Language :: Python",
- "Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.4",
- "Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
],
)