diff options
author | Paul Tax <paultax@gmail.com> | 2015-08-24 21:03:03 +0200 |
---|---|---|
committer | Paul Tax <paultax@gmail.com> | 2015-08-24 21:03:03 +0200 |
commit | 5be488383fea8b514cedc02ec9b9031bc411107d (patch) | |
tree | 470856656e60ce7207bb5cccd6a51989f703b763 | |
parent | 28973f0821d2fabe5a696d4eed0b2a66925038fe (diff) | |
download | python-requests-aws-5be488383fea8b514cedc02ec9b9031bc411107d.tar.gz |
Add travis again
-rw-r--r-- | .gitignore | 2 | ||||
-rw-r--r-- | .travis.yml | 12 | ||||
-rw-r--r-- | README.md | 4 | ||||
-rw-r--r-- | requirements.txt | 2 |
4 files changed, 17 insertions, 3 deletions
@@ -1,4 +1,6 @@ .DS_Store +dist/ +requests_aws.egg-info/ env/ *.pyc *.*~
\ No newline at end of file diff --git a/.travis.yml b/.travis.yml new file mode 100644 index 0000000..1df5645 --- /dev/null +++ b/.travis.yml @@ -0,0 +1,12 @@ +language: python +python: + - "2.6" + - "2.6" + - "2.7" + - "3.2" + - "3.3" + - "3.4" +install: + - pip install requests +# command to run tests, e.g. python setup.py test +script: python test.py
\ No newline at end of file @@ -2,7 +2,9 @@ AWS authentication for Amazon S3 for the wonderful [pyhon requests library](http://python-requests.org) -- Tested with python 2.6 and python 3.3.2 +[](https://travis-ci.org/tax/python-requests-aws) + +- Tested with python 2.7 and python 3 - At the moment only S3 is supported ## Usage diff --git a/requirements.txt b/requirements.txt deleted file mode 100644 index 3a3a480..0000000 --- a/requirements.txt +++ /dev/null @@ -1,2 +0,0 @@ -requests==2.7.0 -wheel==0.24.0 |