summaryrefslogtreecommitdiff
path: root/qpid/cpp/boost-1.32-support/main.patch
diff options
context:
space:
mode:
authorRajith Muditha Attapattu <rajith@apache.org>2011-05-27 15:44:23 +0000
committerRajith Muditha Attapattu <rajith@apache.org>2011-05-27 15:44:23 +0000
commit66765100f4257159622cefe57bed50125a5ad017 (patch)
treea88ee23bb194eb91f0ebb2d9b23ff423e3ea8e37 /qpid/cpp/boost-1.32-support/main.patch
parent1aeaa7b16e5ce54f10c901d75c4d40f9f88b9db6 (diff)
parent88b98b2f4152ef59a671fad55a0d08338b6b78ca (diff)
downloadqpid-python-rajith_jms_client.tar.gz
Creating a branch for experimenting with some ideas for JMS client.rajith_jms_client
git-svn-id: https://svn.apache.org/repos/asf/qpid/branches/rajith_jms_client@1128369 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'qpid/cpp/boost-1.32-support/main.patch')
-rw-r--r--qpid/cpp/boost-1.32-support/main.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/qpid/cpp/boost-1.32-support/main.patch b/qpid/cpp/boost-1.32-support/main.patch
new file mode 100644
index 0000000000..433a8f0f25
--- /dev/null
+++ b/qpid/cpp/boost-1.32-support/main.patch
@@ -0,0 +1,37 @@
+Index: configure.ac
+===================================================================
+--- configure.ac (revision 782009)
++++ configure.ac (working copy)
+@@ -66,7 +66,6 @@
+ # -Wunreachable-code -Wpadded -Winline
+ # -Wshadow - warns about boost headers.
+ if test "${enableval}" = yes; then
+- gl_COMPILER_FLAGS(-Werror)
+ gl_COMPILER_FLAGS(-pedantic)
+ gl_COMPILER_FLAGS(-Wall)
+ gl_COMPILER_FLAGS(-Wextra)
+Index: src/Makefile.am
+===================================================================
+--- src/Makefile.am (revision 782009)
++++ src/Makefile.am (working copy)
+@@ -59,7 +59,7 @@
+ qpid/broker/windows/BrokerDefaults.cpp \
+ qpid/broker/windows/SaslAuthenticator.cpp
+
+-EXTRA_DIST= $(platform_dist) $(rgen_srcs) $(windows_dist)
++EXTRA_DIST= $(platform_dist) $(rgen_srcs) $(windows_dist) $(top_srcdir)/src/boost
+
+ ## Generated code
+
+Index: examples/makedist.mk
+===================================================================
+--- examples/makedist.mk (revision 830311)
++++ examples/makedist.mk (working copy)
+@@ -1,6 +1,6 @@
+ # Settings to build the examples in automake
+ AM_CXXFLAGS = $(WARNING_CFLAGS)
+-INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include
++INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_srcdir)/src
+ CLIENT_LIB=$(top_builddir)/src/libqpidclient.la
+ CONSOLE_LIB=$(top_builddir)/src/libqmfconsole.la
+ CLIENTFLAGS=-lqpidclient