summaryrefslogtreecommitdiff
path: root/cpp/bootstrap
diff options
context:
space:
mode:
Diffstat (limited to 'cpp/bootstrap')
-rwxr-xr-xcpp/bootstrap48
1 files changed, 0 insertions, 48 deletions
diff --git a/cpp/bootstrap b/cpp/bootstrap
deleted file mode 100755
index d6ff19765b..0000000000
--- a/cpp/bootstrap
+++ /dev/null
@@ -1,48 +0,0 @@
-#!/bin/sh
-#
-# Licensed to the Apache Software Foundation (ASF) under one
-# or more contributor license agreements. See the NOTICE file
-# distributed with this work for additional information
-# regarding copyright ownership. The ASF licenses this file
-# to you under the Apache License, Version 2.0 (the
-# "License"); you may not use this file except in compliance
-# with the License. You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing,
-# software distributed under the License is distributed on an
-# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
-# KIND, either express or implied. See the License for the
-# specific language governing permissions and limitations
-# under the License.
-#
-
-# Copy the global QPID_VERSION.txt file into the source tree.
-cp ../QPID_VERSION.txt .
-
-aclocal -I m4
-autoheader
-libtoolize --automake
-
-# Create initial Makefile fragments that will force make to generate
-# the real ones.
-cat > src/rubygen.mk <<EOF
-\$(srcdir)/rubygen.mk: force
- \$(rgen_cmd) \$(srcdir)/rubygen.mk
-EOF
-cat > src/managementgen.mk <<EOF
-\$(srcdir)/managementgen.mk: force
- \$(mgen_cmd)
-EOF
-
-automake --add-missing
-autoconf
-
-# Optionally do the build as well.
-if [ "$1" = "-build" -o "$1" = "--build" ] ; then
- shift
- ./configure "$@"
- make
- make check
-fi