diff options
author | Mehdi ABAAKOUK <sileht@sileht.net> | 2023-03-16 12:51:19 +0100 |
---|---|---|
committer | GitHub <noreply@github.com> | 2023-03-16 13:51:19 +0200 |
commit | 25e85e51e57b7aae9eb8fc77cfb0a45a07a501a7 (patch) | |
tree | 9b781b1b730dcd14bdfb10f0ba8a96c2866256f7 /setup.py | |
parent | 91ab12a0f1bdf0e433131e1a51578e9fa2f89718 (diff) | |
download | redis-py-25e85e51e57b7aae9eb8fc77cfb0a45a07a501a7.tar.gz |
fix: replace async_timeout by asyncio.timeout (#2602)
async_timeout does not support python 3.11
https://github.com/aio-libs/async-timeout/pull/295
And have two years old annoying bugs:
https://github.com/aio-libs/async-timeout/issues/229
https://github.com/redis/redis-py/issues/2551
Since asyncio.timeout has been shipped in python 3.11, we should start
using it.
Partially fixes 2551
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -34,7 +34,7 @@ setup( install_requires=[ 'importlib-metadata >= 1.0; python_version < "3.8"', 'typing-extensions; python_version<"3.8"', - "async-timeout>=4.0.2", + 'async-timeout>=4.0.2; python_version<"3.11"', ], classifiers=[ "Development Status :: 5 - Production/Stable", |