diff options
author | Chayim <chayim@users.noreply.github.com> | 2021-12-15 17:00:39 +0200 |
---|---|---|
committer | GitHub <noreply@github.com> | 2021-12-15 17:00:39 +0200 |
commit | c858f8e9157dbb7915fac6d6920c31b12c061ab0 (patch) | |
tree | 5d46ab143ecbf1ff5c9d2cdf5697fcc7cf3aa527 /setup.py | |
parent | d17ff5913e375568eaab4c5d9a798d249aabe1e4 (diff) | |
download | redis-py-c858f8e9157dbb7915fac6d6920c31b12c061ab0.tar.gz |
Single sourcing the package version (#1791)
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 8 |
1 files changed, 2 insertions, 6 deletions
@@ -1,8 +1,6 @@ #!/usr/bin/env python from setuptools import find_packages, setup -import redis - setup( name="redis", description="Python client for Redis database and key-value store", @@ -10,7 +8,7 @@ setup( long_description_content_type="text/markdown", keywords=["Redis", "key-value store", "database"], license="MIT", - version=redis.__version__, + version="4.1.0rc2", packages=find_packages( include=[ "redis", @@ -26,12 +24,10 @@ setup( author="Redis Inc.", author_email="oss@redis.com", python_requires=">=3.6", - setup_requires=[ - "packaging>=21.3", - ], install_requires=[ "deprecated>=1.2.3", "packaging>=21.3", + 'importlib-metadata >= 1.0; python_version < "3.8"', ], classifiers=[ "Development Status :: 5 - Production/Stable", |