summaryrefslogtreecommitdiff
path: root/lib/sqlalchemy/dialects/mysql/json.py
diff options
context:
space:
mode:
authorMike Bayer <mike_mp@zzzcomputing.com>2019-01-05 22:42:08 -0500
committerMike Bayer <mike_mp@zzzcomputing.com>2019-01-05 23:51:34 -0500
commit404e69426b05a82d905cbb3ad33adafccddb00dd (patch)
tree05e05dc66772923a31842a7fa9869805be879338 /lib/sqlalchemy/dialects/mysql/json.py
parentd229360a8d4071c2f150558897f37e13eb09f430 (diff)
downloadsqlalchemy-404e69426b05a82d905cbb3ad33adafccddb00dd.tar.gz
Assorted pre-Black fixes
Fixes to the test suite, a few errant imports, and setup.py: - mysql and postgresql have unused 'json' imports; remove - postgresql is exporting the 'json' symbol, remove - make sure setup.py can find __version__ using " or ' - retry logic in provision create database for postgresql fixed - refactor test_magazine to use cls.tables rather than globals - remove unused class in test_scoping - add a comment to test_deprecations that this test suite itself is deprecated - don't use mapper() and orm_mapper() in test_unitofwork, just use mapper() - remove dupe test_scalar_set_None test in test_attributes - Python 2.7 and above includes unittest.SkipTest, remove pre-2.7 fallback - use imported SkipTest in profiling - declarative test_reflection tests with "reflectable_autoincrement" already don't run on oracle or firebird; remove conditional logic for these, which also removes an "id" symbol - clean up test in test_functions, remove print statement - remove dupe test_literal_processor_coercion_native_int_out_of_range in test/sql/test_types.py - fix psycopg2_hstore ref Change-Id: I7b3444f8546aac82be81cd1e7b6d8b2ad6834fe6
Diffstat (limited to 'lib/sqlalchemy/dialects/mysql/json.py')
-rw-r--r--lib/sqlalchemy/dialects/mysql/json.py2
1 files changed, 0 insertions, 2 deletions
diff --git a/lib/sqlalchemy/dialects/mysql/json.py b/lib/sqlalchemy/dialects/mysql/json.py
index 84dcefc88..534fb989d 100644
--- a/lib/sqlalchemy/dialects/mysql/json.py
+++ b/lib/sqlalchemy/dialects/mysql/json.py
@@ -7,8 +7,6 @@
from __future__ import absolute_import
-import json
-
from ...sql import elements
from ... import types as sqltypes
from ... import util