diff options
author | Mike Bayer <mike_mp@zzzcomputing.com> | 2013-06-30 18:35:12 -0400 |
---|---|---|
committer | Mike Bayer <mike_mp@zzzcomputing.com> | 2013-06-30 18:35:12 -0400 |
commit | b38a76cd1d47cd6b8f1abef30ad7c3aeaa27d537 (patch) | |
tree | 7af1dba9e242c77a248cb2194434aa9bf3ca49b7 /setup.py | |
parent | 715d6cf3d10a71acd7726b7e00c3ff40b4559bc7 (diff) | |
download | sqlalchemy-b38a76cd1d47cd6b8f1abef30ad7c3aeaa27d537.tar.gz |
- replace most explicitly-named test objects called "Mock..." with
actual mock objects from the mock library. I'd like to use mock
for new tests so we might as well use it in obvious places.
- use unittest.mock in py3.3
- changelog
- add a note to README.unittests
- add tests_require in setup.py
- have tests import from sqlalchemy.testing.mock
- apply usage of mock to one of the event tests. we can be using
this approach all over the place.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 3 |
1 files changed, 1 insertions, 2 deletions
@@ -119,8 +119,7 @@ def run_setup(with_cext): package_dir={'': 'lib'}, license="MIT License", cmdclass=cmdclass, - - tests_require=['nose >= 0.11'], + tests_require=['nose >= 0.11', 'mock'], test_suite="sqla_nose", long_description=readme, classifiers=[ |