summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorFederico Caselli <cfederico87@gmail.com>2022-01-05 21:31:31 +0100
committerFederico Caselli <cfederico87@gmail.com>2022-01-05 20:33:09 +0000
commitc87a08ed8f383466f252c2054bd44b87102149b1 (patch)
treee5998c4d9ec3ebb8430497db7c450178d6acc494 /setup.py
parent400bf1716f84821d63daaf0a988d725dfd55d6a0 (diff)
downloadsqlalchemy-c87a08ed8f383466f252c2054bd44b87102149b1.tar.gz
Fix AttributeError typo in setup.py that prevented fallback
pure python build if the compilation fails Fixes: #7539 Change-Id: I4bf7905eb7a5337213ce922d005d2fffb8b9079c
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 500be62a9..604958922 100644
--- a/setup.py
+++ b/setup.py
@@ -165,7 +165,7 @@ else:
raise
status_msgs(
- exc.cause,
+ exc.__cause__,
"WARNING: The Cython extension could not be compiled, "
"speedups are not enabled.",
"Failure information, if any, is above.",