diff options
author | Mike Bayer <mike_mp@zzzcomputing.com> | 2021-01-27 12:57:47 -0500 |
---|---|---|
committer | Mike Bayer <mike_mp@zzzcomputing.com> | 2021-01-27 13:08:01 -0500 |
commit | e3fbbf830fef9bedee7b26460c79843780962bc0 (patch) | |
tree | 5239eb20fa8d3ef4f3f7c59924dc18039fd0c4ee /setup.py | |
parent | 25ee5a05df0daeb7dc7ba432172d6abc76ffab56 (diff) | |
download | sqlalchemy-e3fbbf830fef9bedee7b26460c79843780962bc0.tar.gz |
Repair incorrect symbol PyDict_GetItemWithError for Python 2
* ensure on python 2 correct cflags to fail on undefined
symbols take effect
* fail for implicit function declaration
* python 2 does not publish PyDict_GetItemWithError but has
it as _PyDict_GetItemWIthError but only as of Python 2.7.12
Change-Id: I007509afddf7f44ca64e52fa9140be39f815fa7a
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -22,9 +22,9 @@ if sys.platform == "win32": # Work around issue https://github.com/pypa/setuptools/issues/1902 ext_errors += (IOError, TypeError) extra_compile_args = [] -elif sys.platform == "linux": +elif sys.platform in ("linux", "linux2"): # warn for undefined symbols in .c files - extra_compile_args = ["-Wundef"] + extra_compile_args = ["-Wundef", "-Werror=implicit-function-declaration"] else: extra_compile_args = [] |