diff options
author | Mike Bayer <mike_mp@zzzcomputing.com> | 2017-01-17 15:51:02 -0500 |
---|---|---|
committer | Mike Bayer <mike_mp@zzzcomputing.com> | 2017-01-17 15:51:02 -0500 |
commit | f2028dc5afec506fd3ad8c78b0275e76bf172b2a (patch) | |
tree | a82aee91a3f38a45d2ae8fb06989ba522bc60530 /setup.py | |
parent | f624a3ae8baadba4dabb55e5851a27d40a6cf73e (diff) | |
download | sqlalchemy-f2028dc5afec506fd3ad8c78b0275e76bf172b2a.tar.gz |
- further changes to avoid pytest warnings
Change-Id: Ia83a996ff97a6ba54a0666a32241e570f3852ab4
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -93,10 +93,10 @@ class PyTest(TestCommand): self.test_suite = True def run_tests(self): + import shlex # import here, cause outside the eggs aren't loaded import pytest - errno = pytest.main( - " ".join(self.default_options) + " " + self.pytest_args) + errno = pytest.main(self.default_options + shlex.split(self.pytest_args)) sys.exit(errno) cmdclass['test'] = PyTest |