diff options
author | Jelmer Vernooij <jelmer@jelmer.uk> | 2022-11-17 00:38:09 +0000 |
---|---|---|
committer | Jelmer Vernooij <jelmer@jelmer.uk> | 2022-11-17 00:38:09 +0000 |
commit | 52ba9e78e36d421a7417cac56a1ae577607aa24b (patch) | |
tree | baf137dca80b41c9d65b742f992c96e7c5d05e13 | |
parent | e613fd65a42bb1255ec2f43e3b36ce98040df454 (diff) | |
download | subunit-git-1.4.2.tar.gz |
Release 1.4.2.1.4.2
-rw-r--r-- | NEWS | 2 | ||||
-rw-r--r-- | README.rst | 2 | ||||
-rw-r--r-- | configure.ac | 2 | ||||
-rw-r--r-- | python/subunit/__init__.py | 2 |
4 files changed, 5 insertions, 3 deletions
@@ -11,6 +11,8 @@ IMPROVEMENTS BUG FIXES ~~~~~~~~~ +* Fix "subunit-filter --fixup-expected-failures" + on Python 3. (Jelmer Vernooij) 1.4.1 @@ -487,7 +487,7 @@ Releases * Update versions in configure.ac and python/subunit/__init__.py. * Update NEWS. * Do a make distcheck, which will update Makefile etc. -* Do a PyPI release: PYTHONPATH=../../python python ../../setup.py sdist bdist_wheel upload -s +* Do a PyPI release: PYTHONPATH=python python setup.py sdist bdist_wheel; twine upload -s dist/* * Upload the regular one to LP. * Push a tagged commit. git push -t origin master:master diff --git a/configure.ac b/configure.ac index ee4fdd4..5e1dec8 100644 --- a/configure.ac +++ b/configure.ac @@ -1,6 +1,6 @@ m4_define([SUBUNIT_MAJOR_VERSION], [1]) m4_define([SUBUNIT_MINOR_VERSION], [4]) -m4_define([SUBUNIT_MICRO_VERSION], [1]) +m4_define([SUBUNIT_MICRO_VERSION], [2]) m4_define([SUBUNIT_VERSION], m4_defn([SUBUNIT_MAJOR_VERSION]).m4_defn([SUBUNIT_MINOR_VERSION]).m4_defn([SUBUNIT_MICRO_VERSION])) AC_PREREQ([2.59]) diff --git a/python/subunit/__init__.py b/python/subunit/__init__.py index 7318a29..971e408 100644 --- a/python/subunit/__init__.py +++ b/python/subunit/__init__.py @@ -151,7 +151,7 @@ from subunit.v2 import ByteStreamToStreamResult, StreamResultToBytes # If the releaselevel is 'final', then the tarball will be major.minor.micro. # Otherwise it is major.minor.micro~$(revno). -__version__ = (1, 4, 1, 'final', 0) +__version__ = (1, 4, 2, 'final', 0) PROGRESS_SET = 0 PROGRESS_CUR = 1 |