summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2014-08-27 12:43:14 +1200
committerRobert Collins <robertc@robertcollins.net>2014-08-27 12:43:14 +1200
commit0188053444eb673c122eb2a94e0c92676217a72d (patch)
tree50dc450ea84adfd3c84e1c54a711159ca252d11b /setup.py
parent57132315d94ead9d4cefdfc95a46f1cc3171c6a3 (diff)
downloadsubunit-git-0188053444eb673c122eb2a94e0c92676217a72d.tar.gz
Release 0.0.200.0.20
Also * The python-subunit tarball can now have setup run from the current directory. (Robert Collins, #1361857)
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 9176398..42ff760 100755
--- a/setup.py
+++ b/setup.py
@@ -36,7 +36,9 @@ VERSION = (
or "0.0")
-os.chdir(os.path.dirname(__file__))
+relpath = os.path.dirname(__file__)
+if relpath:
+ os.chdir(relpath)
setup(
name='python-subunit',
version=VERSION,