summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMatthew Treinish <mtreinish@kortar.org>2019-12-09 11:12:26 -0500
committerMatthew Treinish <mtreinish@kortar.org>2019-12-09 11:12:26 -0500
commit95e0170d59664da570f3f379c4433e4b6a69f2b5 (patch)
treea78b980dd4cc35b45d244c39da7ebf3a2faa61a0 /setup.py
parent8e79501adca5df505436e942fff15c76916c0de1 (diff)
downloadsubunit-git-95e0170d59664da570f3f379c4433e4b6a69f2b5.tar.gz
Add support for new python versions and update pkg metadata
This commit updates the supported python versions for subunit to include support for newer versions of the language 3.7 and 3.8 which have been released since the last python-subunit release. At the same time it takes the opportunity to update the package metadata to add more details including the new python versions.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py11
1 files changed, 11 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 54b1a32..95ffbd1 100755
--- a/setup.py
+++ b/setup.py
@@ -53,14 +53,25 @@ setup(
long_description=open('README.rst').read(),
classifiers=[
'Intended Audience :: Developers',
+ 'Operating System :: OS Independent',
'Programming Language :: Python :: 3',
'Programming Language :: Python',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Topic :: Software Development :: Testing',
],
keywords='python test streaming',
author='Robert Collins',
author_email='subunit-dev@lists.launchpad.net',
url='http://launchpad.net/subunit',
+ project_urls={
+ "Bug Tracker": "https://bugs.launchpad.net/subunit",
+ "Source Code": "https://github.com/testing-cabal/subunit/",
+ },
packages=['subunit', 'subunit.tests'],
package_dir={'subunit': 'python/subunit'},
scripts = [