summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMatthew Treinish <mtreinish@kortar.org>2020-03-14 09:30:16 -0400
committerGitHub <noreply@github.com>2020-03-14 09:30:16 -0400
commitb64a50fea21a0ba45b18f8d1a2c21e06a330cc8c (patch)
tree1b18e4b3e4d201d8589e776b10932b3638f58e65 /setup.py
parent87300ad826336f898a752d8d7bd10cdc5f039d08 (diff)
parent26d31fa7c34019fad9038addf8114bbb4b656c92 (diff)
downloadsubunit-git-b64a50fea21a0ba45b18f8d1a2c21e06a330cc8c.tar.gz
Merge branch 'master' into fix-filter-entrypoints
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py15
1 files changed, 14 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index d963838..dc5dfb1 100755
--- a/setup.py
+++ b/setup.py
@@ -30,15 +30,28 @@ setup(
long_description=open('README.rst').read(),
classifiers=[
'Intended Audience :: Developers',
- 'Programming Language :: Python :: 3',
+ 'Operating System :: OS Independent',
'Programming Language :: Python',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Topic :: Software Development :: Testing',
],
keywords='python test streaming',
author='Robert Collins',
author_email='subunit-dev@lists.launchpad.net',
url='http://launchpad.net/subunit',
+ license='Apache-2.0 or BSD',
+ project_urls={
+ "Bug Tracker": "https://bugs.launchpad.net/subunit",
+ "Source Code": "https://github.com/testing-cabal/subunit/",
+ },
+ packages=['subunit', 'subunit.tests'],
packages=['subunit', 'subunit.tests', 'subunit.filter_scripts'],
+
package_dir={'subunit': 'python/subunit'},
entry_points={
'console_scripts': [