diff options
author | Christophe Vu-Brugier <cvubrugier@yahoo.fr> | 2013-08-28 14:41:10 +0200 |
---|---|---|
committer | Christophe Vu-Brugier <cvubrugier@yahoo.fr> | 2013-08-29 09:30:38 +0200 |
commit | 1d16c8ef704a7260d31c5b5f73c50ceda06c539d (patch) | |
tree | 44d1daf8122123096e09c5a7237350a58d48e85d /setup.py | |
parent | ad309ab1b662cbaf5d1a1c8ccd70901b8a16d4cd (diff) | |
download | targetcli-1d16c8ef704a7260d31c5b5f73c50ceda06c539d.tar.gz |
Put package information in setup.py instead of importing the targetcli module
Also update the package name, version, URL and maintainer.
Signed-off-by: Christophe Vu-Brugier <cvubrugier@yahoo.fr>
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 32 |
1 files changed, 13 insertions, 19 deletions
@@ -16,25 +16,19 @@ License for the specific language governing permissions and limitations under the License. ''' -import re from distutils.core import setup -import targetcli -PKG = targetcli -VERSION = str(PKG.__version__) -(AUTHOR, EMAIL) = re.match('^(.*?)\s*<(.*)>$', PKG.__author__).groups() -URL = PKG.__url__ -LICENSE = PKG.__license__ -SCRIPTS = ["scripts/targetcli"] -DESCRIPTION = PKG.__description__ +__version__ = '' +execfile('targetcli/version.py') -setup(name=PKG.__name__, - description=DESCRIPTION, - version=VERSION, - author=AUTHOR, - author_email=EMAIL, - license=LICENSE, - url=URL, - scripts=SCRIPTS, - packages=[PKG.__name__], - package_data = {'':[]}) +setup( + name = 'targetcli-fb', + version = __version__, + description = 'An administration shell for RTS storage targets.', + license = 'Apache 2.0', + maintainer = 'Andy Grover', + maintainer_email = 'agrover@redhat.com', + url = 'http://github.com/agrover/targetcli-fb', + packages = ['targetcli'], + scripts = ['scripts/targetcli'], + ) |