summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNicholas Bellinger <nab@risingtidesystems.com>2011-05-04 21:14:18 +0000
committerNicholas Bellinger <nab@risingtidesystems.com>2011-05-04 21:14:18 +0000
commitdb0c7fd76abc5fcc929b039f2d49f1a38f947968 (patch)
treee2d8b8535610d8e6d2c9d1b305230be376d15887 /setup.py
downloadtargetcli-db0c7fd76abc5fcc929b039f2d49f1a38f947968.tar.gz
initial rtsadmin commit1.99
Signed-off-by: Nicholas Bellinger <nab@risingtidesystems.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py43
1 files changed, 43 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..7968530
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,43 @@
+#! /usr/bin/env python
+
+'''
+This file is part of RTSAdmin Community Edition.
+Copyright (c) 2011 by RisingTide Systems LLC
+
+This program is free software: you can redistribute it and/or modify
+it under the terms of the GNU Affero General Public License as
+published by the Free Software Foundation, version 3 (AGPLv3).
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU Affero General Public License for more details.
+
+You should have received a copy of the GNU Affero General Public License
+along with this program. If not, see <http://www.gnu.org/licenses/>.
+'''
+
+import re
+from distutils.core import setup
+import rtsadmin
+
+PKG = rtsadmin
+VERSION = str(PKG.__version__)
+(AUTHOR, EMAIL) = re.match('^(.*?)\s*<(.*)>$', PKG.__author__).groups()
+URL = PKG.__url__
+LICENSE = PKG.__license__
+SCRIPTS = ["scripts/rtsadmin"]
+DESCRIPTION = PKG.__description__
+
+setup(
+ name=PKG.__name__,
+ description=DESCRIPTION,
+ version=VERSION,
+ author=AUTHOR,
+ author_email=EMAIL,
+ license=LICENSE,
+ url=URL,
+ scripts=SCRIPTS,
+ packages=[PKG.__name__],
+ package_data = {'':[]}
+ )