summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2013-02-08 00:49:30 +1300
committerRobert Collins <robertc@robertcollins.net>2013-02-08 00:49:30 +1300
commitad6b3a65ad70dd5ea10e22614bc157c86f9c3a2c (patch)
treec91104fddb3ce3bf80dd75dee2c1375a58cb189d /setup.py
parentdf826845eeba5146e89431e59cb1c5391b59e829 (diff)
downloadtestrepository-git-ad6b3a65ad70dd5ea10e22614bc157c86f9c3a2c.tar.gz
0.0.14
++++++ IMPROVEMENTS ------------ * First cut at full Python 3 support. The 'works for me' release. (Robert Collins)
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 0c3bc38..9582c04 100755
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
#!/usr/bin/env python
#
-# Copyright (c) 2009, 2010 Testrepository Contributors
+# Copyright (c) 2009-2013 Testrepository Contributors
#
# Licensed under either the Apache License, Version 2.0 or the BSD 3-clause
# license at the users choice. A copy of both licenses are available in the
@@ -59,7 +59,7 @@ def get_version():
return version + '-r%s' % revno
-description = file(os.path.join(os.path.dirname(__file__), 'README.txt'), 'rb').read()
+description = open(os.path.join(os.path.dirname(__file__), 'README.txt'), 'rt').read()
setup(name='testrepository',
@@ -95,8 +95,8 @@ setup(name='testrepository',
],
install_requires=[
'fixtures',
- 'python-subunit',
- 'testtools',
+ 'python-subunit >= 0.0.10',
+ 'testtools >= 0.9.29',
],
extras_require = dict(
test=[