summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernát Gábor <bgabor8@bloomberg.net>2021-02-15 08:00:44 +0000
committerBernát Gábor <bgabor8@bloomberg.net>2021-02-15 08:00:44 +0000
commita33c3ffaed3b447c370c80198fc01c2f67bb15ed (patch)
tree1979dd19c3c37d83301d478004be1a396a6baa6c
parent098f047fae45362ef3f66589d31b5e40cd185185 (diff)
downloadtox-git-release-4.0.0a6.tar.gz
release 4.0.0a64.0.0a6release-4.0.0a6
-rw-r--r--docs/changelog.rst56
-rw-r--r--docs/changelog/1829.bugfix.rst2
-rw-r--r--docs/changelog/1829.feature.rst1
-rw-r--r--docs/changelog/1831.bugfix.rst1
-rw-r--r--docs/changelog/1831.feature.rst2
-rw-r--r--docs/changelog/1832.feature.rst1
-rw-r--r--docs/changelog/1833.bugfix.rst2
-rw-r--r--docs/changelog/1838.feature.rst3
-rw-r--r--docs/changelog/1839.bugfix.rst1
-rw-r--r--docs/changelog/1839.feature.rst1
-rw-r--r--docs/changelog/1839.removal.rst6
-rw-r--r--docs/changelog/1841.removal.rst4
-rw-r--r--docs/changelog/1842.feature.rst2
-rw-r--r--docs/changelog/1843.bugfix.rst2
-rw-r--r--docs/changelog/1843.feature.rst1
-rw-r--r--docs/changelog/1844.feature.rst1
-rw-r--r--docs/changelog/1845.feature.rst1
-rw-r--r--docs/changelog/1846.feature.rst1
-rw-r--r--docs/changelog/1900.feature.rst1
-rw-r--r--docs/changelog/1903.bugfix.rst1
-rw-r--r--docs/changelog/1906.feature.rst2
-rw-r--r--docs/changelog/1909.feature.rst2
-rw-r--r--docs/changelog/1915.bugfix.rst2
-rw-r--r--docs/changelog/1915.feature.rst3
-rw-r--r--pyproject.toml3
25 files changed, 57 insertions, 45 deletions
diff --git a/docs/changelog.rst b/docs/changelog.rst
index 65eeacfd..2c891862 100644
--- a/docs/changelog.rst
+++ b/docs/changelog.rst
@@ -5,6 +5,62 @@ Release History
.. towncrier release notes start
+4.0.0a6 (2021-02-15)
+--------------------
+
+Features - 4.0.0a6
+~~~~~~~~~~~~~~~~~~
+- Add basic quickstart implementation (just use pytest with the current python version) - by :user:`gaborbernat`. (`#1829 <https://github.com/tox-dev/tox/issues/1829>`_)
+- Support comments via the ``#`` character within the ini configuration (to force a literal ``#`` use ``\#``) -
+ by :user:`gaborbernat`. (`#1831 <https://github.com/tox-dev/tox/issues/1831>`_)
+- Add support for the ``install_command`` settings in the virtual env test environments - by :user:`gaborbernat`. (`#1832 <https://github.com/tox-dev/tox/issues/1832>`_)
+- Add support for the ``package_root`` \ ``setupdir`` (python scoped) configuration that sets the root directory used for
+ packaging (the location of the historical ``setup.py`` and modern ``pyproject.toml``). This can be set at root level, or
+ at tox environment level (the later takes precedence over the former) - by :user:`gaborbernat`. (`#1838 <https://github.com/tox-dev/tox/issues/1838>`_)
+- Implement support for the ``--installpkg`` CLI flag - by :user:`gaborbernat`. (`#1839 <https://github.com/tox-dev/tox/issues/1839>`_)
+- Add support for the ``list_dependencies_command`` settings in the virtual env test environments - by
+ :user:`gaborbernat`. (`#1842 <https://github.com/tox-dev/tox/issues/1842>`_)
+- Add support for the ``ignore_errors`` settings in tox test environments - by :user:`gaborbernat`. (`#1843 <https://github.com/tox-dev/tox/issues/1843>`_)
+- Add support for the ``pip_pre`` settings for virtual environment based tox environments - by :user:`gaborbernat`. (`#1844 <https://github.com/tox-dev/tox/issues/1844>`_)
+- Add support for the ``platform`` settings in tox test environments - by :user:`gaborbernat`. (`#1845 <https://github.com/tox-dev/tox/issues/1845>`_)
+- Add support for the ``recreate`` settings in tox test environments - by :user:`gaborbernat`. (`#1846 <https://github.com/tox-dev/tox/issues/1846>`_)
+- Allow python test and packaging environments with version 2.7 - by :user:`gaborbernat`. (`#1900 <https://github.com/tox-dev/tox/issues/1900>`_)
+- Do not construct a requirements file for deps in virtualenv, instead pass content as CLI argument to pip - by
+ :user:`gaborbernat`. (`#1906 <https://github.com/tox-dev/tox/issues/1906>`_)
+- Do not display status update environment reports when interrupted or for the final environment ran (because at the
+ final report will be soon printed and makes the status update redundant) - by :user:`gaborbernat`. (`#1909 <https://github.com/tox-dev/tox/issues/1909>`_)
+- The ``_TOX_SHOW_THREAD`` environment variable can be used to print alive threads when tox exists (useful to debug
+ when tox hangs because of some non-finished thread) and also now prints the pid of the local subprocess when reporting
+ the outcome of a execution - by :user:`gaborbernat`. (`#1915 <https://github.com/tox-dev/tox/issues/1915>`_)
+
+Bugfixes - 4.0.0a6
+~~~~~~~~~~~~~~~~~~
+- Normalize description text to collapse newlines and one or more than whitespace to a single space - by
+ :user:`gaborbernat`. (`#1829 <https://github.com/tox-dev/tox/issues/1829>`_)
+- Support aliases in show config key specification (will print with the primary key) - by :user:`gaborbernat`. (`#1831 <https://github.com/tox-dev/tox/issues/1831>`_)
+- Show config no longer marks as unused keys that are inherited (e.g. if the key is coming from ``testenv`` section and our
+ target is ``testenv:fix``) - by :user:`gaborbernat`. (`#1833 <https://github.com/tox-dev/tox/issues/1833>`_)
+- ``--alwayscopy`` and ``--sitepackages`` legacy only flags do not work - by :user:`gaborbernat`. (`#1839 <https://github.com/tox-dev/tox/issues/1839>`_)
+- Fix handling of ``commands_pre``/``commands``/``commands_post`` to be in line with tox 3 (returned incorrect exit codes
+ and post was not always executed) - by :user:`gaborbernat`. (`#1843 <https://github.com/tox-dev/tox/issues/1843>`_)
+- Support requirement files containing ``--hash`` constraints - by :user:`gaborbernat`. (`#1903 <https://github.com/tox-dev/tox/issues/1903>`_)
+- Fix a bug that caused tox to never finish when pulling configuration from a tox run environment that was never executed
+ - by :user:`gaborbernat`. (`#1915 <https://github.com/tox-dev/tox/issues/1915>`_)
+
+Deprecations and Removals - 4.0.0a6
+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+- - Drop support for ``sdistsrc`` flag because introduces a significant complexity and is barely used (5 hits on a github
+ search).
+ - ``--skip-missing-interpreters``, ``--notest``, ``--sdistonly``, ``--installpkg``, ``--develop`` and
+ ``--skip-pkg-install`` CLI flags are no longer available for ``devenv`` (enforce the only sane value for these).
+
+ By :user:`gaborbernat` (`#1839 <https://github.com/tox-dev/tox/issues/1839>`_)
+- Remove Jenkins override support: this feature goes against the spirit of tox - blurring the line between the CI and
+ local runs. It also singles out a single CI provider, which opens the door for other CIs wanting similar functionality.
+ Finally, only 54 code file examples came back on a Github search, showing this is a not widely used feature. People who
+ still want Jenkins override support may create a tox plugin to achieve this functionality - by :user:`gaborbernat`. (`#1841 <https://github.com/tox-dev/tox/issues/1841>`_)
+
+
v4.0.0a5 (2021-01-23)
---------------------
diff --git a/docs/changelog/1829.bugfix.rst b/docs/changelog/1829.bugfix.rst
deleted file mode 100644
index 11788661..00000000
--- a/docs/changelog/1829.bugfix.rst
+++ /dev/null
@@ -1,2 +0,0 @@
-Normalize description text to collapse newlines and one or more than whitespace to a single space - by
-:user:`gaborbernat`.
diff --git a/docs/changelog/1829.feature.rst b/docs/changelog/1829.feature.rst
deleted file mode 100644
index 95d15044..00000000
--- a/docs/changelog/1829.feature.rst
+++ /dev/null
@@ -1 +0,0 @@
-Add basic quickstart implementation (just use pytest with the current python version) - by :user:`gaborbernat`.
diff --git a/docs/changelog/1831.bugfix.rst b/docs/changelog/1831.bugfix.rst
deleted file mode 100644
index f5ef2133..00000000
--- a/docs/changelog/1831.bugfix.rst
+++ /dev/null
@@ -1 +0,0 @@
-Support aliases in show config key specification (will print with the primary key) - by :user:`gaborbernat`.
diff --git a/docs/changelog/1831.feature.rst b/docs/changelog/1831.feature.rst
deleted file mode 100644
index c8baa606..00000000
--- a/docs/changelog/1831.feature.rst
+++ /dev/null
@@ -1,2 +0,0 @@
-Support comments via the ``#`` character within the ini configuration (to force a literal ``#`` use ``\#``) -
-by :user:`gaborbernat`.
diff --git a/docs/changelog/1832.feature.rst b/docs/changelog/1832.feature.rst
deleted file mode 100644
index e200401f..00000000
--- a/docs/changelog/1832.feature.rst
+++ /dev/null
@@ -1 +0,0 @@
-Add support for the ``install_command`` settings in the virtual env test environments - by :user:`gaborbernat`.
diff --git a/docs/changelog/1833.bugfix.rst b/docs/changelog/1833.bugfix.rst
deleted file mode 100644
index c04bfc3c..00000000
--- a/docs/changelog/1833.bugfix.rst
+++ /dev/null
@@ -1,2 +0,0 @@
-Show config no longer marks as unused keys that are inherited (e.g. if the key is coming from ``testenv`` section and our
-target is ``testenv:fix``) - by :user:`gaborbernat`.
diff --git a/docs/changelog/1838.feature.rst b/docs/changelog/1838.feature.rst
deleted file mode 100644
index ab13ae8b..00000000
--- a/docs/changelog/1838.feature.rst
+++ /dev/null
@@ -1,3 +0,0 @@
-Add support for the ``package_root`` \ ``setupdir`` (python scoped) configuration that sets the root directory used for
-packaging (the location of the historical ``setup.py`` and modern ``pyproject.toml``). This can be set at root level, or
-at tox environment level (the later takes precedence over the former) - by :user:`gaborbernat`.
diff --git a/docs/changelog/1839.bugfix.rst b/docs/changelog/1839.bugfix.rst
deleted file mode 100644
index 9fa701c1..00000000
--- a/docs/changelog/1839.bugfix.rst
+++ /dev/null
@@ -1 +0,0 @@
-``--alwayscopy`` and ``--sitepackages`` legacy only flags do not work - by :user:`gaborbernat`.
diff --git a/docs/changelog/1839.feature.rst b/docs/changelog/1839.feature.rst
deleted file mode 100644
index 0bc45d1b..00000000
--- a/docs/changelog/1839.feature.rst
+++ /dev/null
@@ -1 +0,0 @@
-Implement support for the ``--installpkg`` CLI flag - by :user:`gaborbernat`.
diff --git a/docs/changelog/1839.removal.rst b/docs/changelog/1839.removal.rst
deleted file mode 100644
index 0279e27c..00000000
--- a/docs/changelog/1839.removal.rst
+++ /dev/null
@@ -1,6 +0,0 @@
-- Drop support for ``sdistsrc`` flag because introduces a significant complexity and is barely used (5 hits on a github
- search).
-- ``--skip-missing-interpreters``, ``--notest``, ``--sdistonly``, ``--installpkg``, ``--develop`` and
- ``--skip-pkg-install`` CLI flags are no longer available for ``devenv`` (enforce the only sane value for these).
-
-By :user:`gaborbernat`
diff --git a/docs/changelog/1841.removal.rst b/docs/changelog/1841.removal.rst
deleted file mode 100644
index 4397d4b3..00000000
--- a/docs/changelog/1841.removal.rst
+++ /dev/null
@@ -1,4 +0,0 @@
-Remove Jenkins override support: this feature goes against the spirit of tox - blurring the line between the CI and
-local runs. It also singles out a single CI provider, which opens the door for other CIs wanting similar functionality.
-Finally, only 54 code file examples came back on a Github search, showing this is a not widely used feature. People who
-still want Jenkins override support may create a tox plugin to achieve this functionality - by :user:`gaborbernat`.
diff --git a/docs/changelog/1842.feature.rst b/docs/changelog/1842.feature.rst
deleted file mode 100644
index e12296f6..00000000
--- a/docs/changelog/1842.feature.rst
+++ /dev/null
@@ -1,2 +0,0 @@
-Add support for the ``list_dependencies_command`` settings in the virtual env test environments - by
-:user:`gaborbernat`.
diff --git a/docs/changelog/1843.bugfix.rst b/docs/changelog/1843.bugfix.rst
deleted file mode 100644
index e5bd4507..00000000
--- a/docs/changelog/1843.bugfix.rst
+++ /dev/null
@@ -1,2 +0,0 @@
-Fix handling of ``commands_pre``/``commands``/``commands_post`` to be in line with tox 3 (returned incorrect exit codes
-and post was not always executed) - by :user:`gaborbernat`.
diff --git a/docs/changelog/1843.feature.rst b/docs/changelog/1843.feature.rst
deleted file mode 100644
index e2850004..00000000
--- a/docs/changelog/1843.feature.rst
+++ /dev/null
@@ -1 +0,0 @@
-Add support for the ``ignore_errors`` settings in tox test environments - by :user:`gaborbernat`.
diff --git a/docs/changelog/1844.feature.rst b/docs/changelog/1844.feature.rst
deleted file mode 100644
index 50e54d8b..00000000
--- a/docs/changelog/1844.feature.rst
+++ /dev/null
@@ -1 +0,0 @@
-Add support for the ``pip_pre`` settings for virtual environment based tox environments - by :user:`gaborbernat`.
diff --git a/docs/changelog/1845.feature.rst b/docs/changelog/1845.feature.rst
deleted file mode 100644
index 9587dcb0..00000000
--- a/docs/changelog/1845.feature.rst
+++ /dev/null
@@ -1 +0,0 @@
-Add support for the ``platform`` settings in tox test environments - by :user:`gaborbernat`.
diff --git a/docs/changelog/1846.feature.rst b/docs/changelog/1846.feature.rst
deleted file mode 100644
index a893b05f..00000000
--- a/docs/changelog/1846.feature.rst
+++ /dev/null
@@ -1 +0,0 @@
-Add support for the ``recreate`` settings in tox test environments - by :user:`gaborbernat`.
diff --git a/docs/changelog/1900.feature.rst b/docs/changelog/1900.feature.rst
deleted file mode 100644
index b51da6c8..00000000
--- a/docs/changelog/1900.feature.rst
+++ /dev/null
@@ -1 +0,0 @@
-Allow python test and packaging environments with version 2.7 - by :user:`gaborbernat`.
diff --git a/docs/changelog/1903.bugfix.rst b/docs/changelog/1903.bugfix.rst
deleted file mode 100644
index 23d1d1d9..00000000
--- a/docs/changelog/1903.bugfix.rst
+++ /dev/null
@@ -1 +0,0 @@
-Support requirement files containing ``--hash`` constraints - by :user:`gaborbernat`.
diff --git a/docs/changelog/1906.feature.rst b/docs/changelog/1906.feature.rst
deleted file mode 100644
index 1b1ae6ea..00000000
--- a/docs/changelog/1906.feature.rst
+++ /dev/null
@@ -1,2 +0,0 @@
-Do not construct a requirements file for deps in virtualenv, instead pass content as CLI argument to pip - by
-:user:`gaborbernat`.
diff --git a/docs/changelog/1909.feature.rst b/docs/changelog/1909.feature.rst
deleted file mode 100644
index a48f2757..00000000
--- a/docs/changelog/1909.feature.rst
+++ /dev/null
@@ -1,2 +0,0 @@
-Do not display status update environment reports when interrupted or for the final environment ran (because at the
-final report will be soon printed and makes the status update redundant) - by :user:`gaborbernat`.
diff --git a/docs/changelog/1915.bugfix.rst b/docs/changelog/1915.bugfix.rst
deleted file mode 100644
index d3e137a9..00000000
--- a/docs/changelog/1915.bugfix.rst
+++ /dev/null
@@ -1,2 +0,0 @@
-Fix a bug that caused tox to never finish when pulling configuration from a tox run environment that was never executed
-- by :user:`gaborbernat`.
diff --git a/docs/changelog/1915.feature.rst b/docs/changelog/1915.feature.rst
deleted file mode 100644
index 562c9dfe..00000000
--- a/docs/changelog/1915.feature.rst
+++ /dev/null
@@ -1,3 +0,0 @@
-The ``_TOX_SHOW_THREAD`` environment variable can be used to print alive threads when tox exists (useful to debug
-when tox hangs because of some non-finished thread) and also now prints the pid of the local subprocess when reporting
-the outcome of a execution - by :user:`gaborbernat`.
diff --git a/pyproject.toml b/pyproject.toml
index d9be1457..116cb76c 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -18,8 +18,7 @@ __version__ = "{version}"
"""
[tool.towncrier]
-package = "tox"
-package_dir = "" # we purposfully do not set this as src, forcing import from site-package that has version.py
+name = "tox"
filename = "docs/changelog.rst"
directory = "docs/changelog"
title_format = false