diff options
author | Tomaz Solc <tomaz.solc@tablix.org> | 2021-03-06 18:04:58 +0100 |
---|---|---|
committer | Tomaz Solc <tomaz.solc@tablix.org> | 2021-03-06 18:04:58 +0100 |
commit | 2cf5c08d589d2bbc1153e5dc42699f2b061b0bb0 (patch) | |
tree | 741a126168abfc0df457952f026e435813aebd3a | |
parent | f743166c4a9bb17f4cafc51e3080a681ae5a1845 (diff) | |
download | unidecode-2cf5c08d589d2bbc1153e5dc42699f2b061b0bb0.tar.gz |
Move README.rst to utf-8 encoding.
This also hopefully makes it clearer that Unidecode is not about decoding \u
escapes.
-rw-r--r-- | README.rst | 4 | ||||
-rw-r--r-- | setup.py | 2 |
2 files changed, 3 insertions, 3 deletions
@@ -57,7 +57,7 @@ containing non-ASCII characters, and returns a string that can be safely encoded to ASCII:: >>> from unidecode import unidecode - >>> unidecode('ko\u017eu\u0161\u010dek') + >>> unidecode('kožušček') 'kozuscek' >>> unidecode('30 \U0001d5c4\U0001d5c6/\U0001d5c1') '30 km/h' @@ -265,7 +265,7 @@ Copyright 2001, Sean M. Burke <sburke@cpan.org>, all rights reserved. Python code and later additions: -Copyright 2021, Tomaz Solc <tomaz.solc@tablix.org> +Copyright 2021, Tomaž Šolc <tomaz.solc@tablix.org> This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free @@ -6,7 +6,7 @@ from setuptools import setup def get_long_description(): - with open(os.path.join(os.path.dirname(__file__), "README.rst")) as fp: + with open(os.path.join(os.path.dirname(__file__), "README.rst"), encoding='utf-8') as fp: return fp.read() setup( |