summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomaz Solc <tomaz.solc@tablix.org>2021-09-10 12:34:12 +0200
committerTomaz Solc <tomaz.solc@tablix.org>2021-09-10 12:34:12 +0200
commitd5ef3c61e1216501ed8024c5bab8f5ad9018824c (patch)
treeec6d2d08e49ce5b7ddf659df4c435f896e209eaa
parent6e1cb5134fe9646bf3b0d4d54cc7ce06a4b748fc (diff)
downloadunidecode-d5ef3c61e1216501ed8024c5bab8f5ad9018824c.tar.gz
Add GitHub actions configuration.
-rw-r--r--.github/workflows/ci.yml32
-rw-r--r--.travis.yml10
-rw-r--r--tox.ini1
3 files changed, 33 insertions, 10 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
new file mode 100644
index 0000000..8fbb8cf
--- /dev/null
+++ b/.github/workflows/ci.yml
@@ -0,0 +1,32 @@
+name: CI
+
+on:
+ push:
+ branches: [ master ]
+ pull_request:
+ branches: [ master ]
+
+jobs:
+ build:
+
+ runs-on: ubuntu-latest
+ strategy:
+ matrix:
+ python-version:
+ - name: 3.7
+ toxenv: py37
+ - name: 3.8
+ toxenv: py38
+ - name: 3.9
+ toxenv: py39
+
+ steps:
+ - uses: actions/checkout@v2
+ - name: Set up Python ${{ matrix.python-version.name }}
+ uses: actions/setup-python@v2
+ with:
+ python-version: ${{ matrix.python-version.name }}
+ - name: Install tox
+ run: python -m pip install tox
+ - name: Run tox
+ run: python -m tox -e "${{ matrix.python-version.toxenv }}"
diff --git a/.travis.yml b/.travis.yml
deleted file mode 100644
index 7343b91..0000000
--- a/.travis.yml
+++ /dev/null
@@ -1,10 +0,0 @@
-dist: xenial
-language: python
-python:
- - 3.5
- - 3.6
- - 3.7
- - 3.8
- - pypy3.5-6.0
-script:
- - python setup.py test
diff --git a/tox.ini b/tox.ini
index c95f8c5..55a16ed 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,6 @@
[tox]
envlist = py{35,36,37,38,39,py3}
+skip_missing_interpreters = true
[testenv]
deps =