diff options
author | Jon Dufresne <jon.dufresne@gmail.com> | 2018-12-31 06:30:14 -0800 |
---|---|---|
committer | Jon Dufresne <jon.dufresne@gmail.com> | 2018-12-31 06:31:30 -0800 |
commit | cd474f6ca457a977a4f6434c58f32e708f98a83d (patch) | |
tree | 7c11fbd450371514a26828328d95330001075445 /setup.py | |
parent | 4b6a097f4ada716639aa1727aaaab64a829a873f (diff) | |
download | unidecode-cd474f6ca457a977a4f6434c58f32e708f98a83d.tar.gz |
Pass python_requires argument to setuptools
Helps pip decide what version of the library to install. Include this
information in the README as well. These versions were already
documented as trove classifiers.
https://packaging.python.org/guides/distributing-packages-using-setuptools/#python-requires
> If your project only runs on certain Python versions, setting the
> python_requires argument to the appropriate PEP 440 version specifier
> string will prevent pip from installing the project on other Python
> versions.
https://setuptools.readthedocs.io/en/latest/setuptools.html#new-and-changed-setup-keywords
> python_requires
>
> A string corresponding to a version specifier (as defined in PEP 440)
> for the Python version, used to specify the Requires-Python defined in
> PEP 345.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 1 |
1 files changed, 1 insertions, 0 deletions
@@ -18,6 +18,7 @@ setup( author_email='tomaz.solc@tablix.org', packages=['unidecode'], + python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*", test_suite='tests', |