summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2018-12-31 06:30:14 -0800
committerJon Dufresne <jon.dufresne@gmail.com>2018-12-31 06:31:30 -0800
commitcd474f6ca457a977a4f6434c58f32e708f98a83d (patch)
tree7c11fbd450371514a26828328d95330001075445 /setup.py
parent4b6a097f4ada716639aa1727aaaab64a829a873f (diff)
downloadunidecode-cd474f6ca457a977a4f6434c58f32e708f98a83d.tar.gz
Pass python_requires argument to setuptools
Helps pip decide what version of the library to install. Include this information in the README as well. These versions were already documented as trove classifiers. https://packaging.python.org/guides/distributing-packages-using-setuptools/#python-requires > If your project only runs on certain Python versions, setting the > python_requires argument to the appropriate PEP 440 version specifier > string will prevent pip from installing the project on other Python > versions. https://setuptools.readthedocs.io/en/latest/setuptools.html#new-and-changed-setup-keywords > python_requires > > A string corresponding to a version specifier (as defined in PEP 440) > for the Python version, used to specify the Requires-Python defined in > PEP 345.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 4baf0bd..0d807df 100644
--- a/setup.py
+++ b/setup.py
@@ -18,6 +18,7 @@ setup(
author_email='tomaz.solc@tablix.org',
packages=['unidecode'],
+ python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
test_suite='tests',