summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Grainger <tagrain@gmail.com>2023-04-14 14:10:31 +0100
committerGitHub <noreply@github.com>2023-04-14 08:10:31 -0500
commit2a0a35bda71409bcdaf267fa9f8b889449b5cdbe (patch)
treeeaaef6f804e70416be6e9fd6acba3c9ed0c8305d
parenta43f604115b84a9521363d3ca7fd09c5ec412e14 (diff)
downloadurllib3-2a0a35bda71409bcdaf267fa9f8b889449b5cdbe.tar.gz
Remove the 'pool' deprecation warning from test suite
-rw-r--r--pyproject.toml1
-rw-r--r--test/test_exceptions.py4
2 files changed, 2 insertions, 3 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 1166f185..d935ff46 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -87,7 +87,6 @@ filterwarnings = [
'''default:'urllib3\[secure\]' extra is deprecated and will be removed in urllib3 v2\.1\.0.*:DeprecationWarning''',
'''default:'urllib3\.contrib\.pyopenssl' module is deprecated and will be removed in urllib3 v2\.1\.0.*:DeprecationWarning''',
'''default:'urllib3\.contrib\.securetransport' module is deprecated and will be removed in urllib3 v2\.1\.0.*:DeprecationWarning''',
- '''default:The 'pool' property is deprecated and will be removed in urllib3 v2\.1\.0\. use 'conn' instead:DeprecationWarning''',
'''default:'ssl_version' option is deprecated and will be removed in urllib3 v2\.1\.0\. Instead use 'ssl_minimum_version':DeprecationWarning''',
'''default:.*:urllib3.exceptions.InsecureRequestWarning''',
'''default:No IPv6 support. Falling back to IPv4:urllib3.exceptions.HTTPWarning''',
diff --git a/test/test_exceptions.py b/test/test_exceptions.py
index 71bc1ec4..8d9eb109 100644
--- a/test/test_exceptions.py
+++ b/test/test_exceptions.py
@@ -57,9 +57,9 @@ class TestNewConnectionError:
def test_pool_property_deprecation_warning(self) -> None:
err = NewConnectionError(HTTPConnection("localhost"), "test")
with pytest.warns(DeprecationWarning) as records:
- err.pool
+ err_pool = err.pool
- assert err.pool is err.conn
+ assert err_pool is err.conn
msg = (
"The 'pool' property is deprecated and will be removed "
"in urllib3 v2.1.0. Use 'conn' instead."