summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernát Gábor <gaborjbernat@gmail.com>2023-04-26 17:46:27 -0700
committerGitHub <noreply@github.com>2023-04-26 17:46:27 -0700
commit699db9e9516c796717c2db3e9014e9b4905725e3 (patch)
tree5b64b02b9d210af42f1593de15d632da7caa9eb1
parent8829b7a41353015ce78a7edc94a8eb1e390f9e1a (diff)
downloadvirtualenv-699db9e9516c796717c2db3e9014e9b4905725e3.tar.gz
Add trusted-publish (#2559)
-rw-r--r--.github/workflows/check.yml1
-rw-r--r--.github/workflows/release.yml27
2 files changed, 28 insertions, 0 deletions
diff --git a/.github/workflows/check.yml b/.github/workflows/check.yml
index 69470c6..4a600f2 100644
--- a/.github/workflows/check.yml
+++ b/.github/workflows/check.yml
@@ -1,6 +1,7 @@
name: check
on:
push:
+ tags-ignore: ["**"]
pull_request:
schedule:
- cron: "0 8 * * *"
diff --git a/.github/workflows/release.yml b/.github/workflows/release.yml
new file mode 100644
index 0000000..dd72c14
--- /dev/null
+++ b/.github/workflows/release.yml
@@ -0,0 +1,27 @@
+name: Release to PyPI
+on:
+ push:
+ tags: ["*"]
+
+jobs:
+ release:
+ runs-on: ubuntu-22.04
+ environment:
+ name: release
+ url: https://pypi.org/p/virtualenv
+ permissions:
+ id-token: write
+ steps:
+ - name: Setup python to build package
+ uses: actions/setup-python@v4
+ with:
+ python-version: "3.11"
+ - name: Install build
+ run: python -m pip install build
+ - uses: actions/checkout@v3
+ with:
+ fetch-depth: 0
+ - name: Build package
+ run: pyproject-build -s -w . -o dist
+ - name: Publish to PyPI
+ uses: pypa/gh-action-pypi-publish@v1.8.5