summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Allgaier <mail@spacegaier.de>2022-04-07 13:58:15 +0200
committerGitHub <noreply@github.com>2022-04-07 13:58:15 +0200
commit2466ee2ffe901cd3df3f8675c1f21b4786b5b58e (patch)
treeec18374e253c30be838363401274e44ef5edd03a
parent51751cab05cc0d08428f3add6502f58968701e8f (diff)
downloadvoluptuous-2466ee2ffe901cd3df3f8675c1f21b4786b5b58e.tar.gz
Release 0.13.1 (#469)0.13.1
-rw-r--r--CHANGELOG.md19
-rw-r--r--setup.py1
-rw-r--r--voluptuous/__init__.py2
3 files changed, 19 insertions, 3 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index ab925f4..0f550b7 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,15 +1,30 @@
# Changelog
+## [0.13.1]
+
+**Fixes**:
+
+- [#439](https://github.com/alecthomas/voluptuous/pull/454): Ignore `Enum` if it is unavailable
+- [#456](https://github.com/alecthomas/voluptuous/pull/456): Fix email regex match for Python 2.7
+
+**New**:
+
+- [#457](https://github.com/alecthomas/voluptuous/pull/457): Enable github actions
+- [#462](https://github.com/alecthomas/voluptuous/pull/462): Convert codebase to adhere to `flake8` W504 (PEP 8)
+- [#459](https://github.com/alecthomas/voluptuous/pull/459): Enable `flake8` in github actions
+- [#464](https://github.com/alecthomas/voluptuous/pull/464): `pytest` migration + enable Python 3.10
+
## [0.13.0]
**Changes**:
-- [#450](https://github.com/alecthomas/voluptuous/pull/450): Display valid Enum values in Coerce
+- [#450](https://github.com/alecthomas/voluptuous/pull/450): Display valid `Enum` values in `Coerce`
## [0.12.2]
**Fixes**:
-- [#439](https://github.com/alecthomas/voluptuous/issues/439): Revert Breaking Maybe change in 0.12.1
+
+- [#439](https://github.com/alecthomas/voluptuous/issues/439): Revert Breaking `Maybe` change in 0.12.1
- [#447](https://github.com/alecthomas/voluptuous/issues/447): Fix Email Regex to not match on extra characters
## [0.12.1]
diff --git a/setup.py b/setup.py
index 0579161..8bb523f 100644
--- a/setup.py
+++ b/setup.py
@@ -36,5 +36,6 @@ setup(
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
]
)
diff --git a/voluptuous/__init__.py b/voluptuous/__init__.py
index 6f9e20b..de178d0 100644
--- a/voluptuous/__init__.py
+++ b/voluptuous/__init__.py
@@ -5,5 +5,5 @@ from voluptuous.validators import *
from voluptuous.util import *
from voluptuous.error import *
-__version__ = '0.13.0'
+__version__ = '0.13.1'
__author__ = 'alecthomas'