summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorengn33r <engn33r@users.noreply.github.com>2021-02-27 17:13:08 -0500
committerengn33r <engn33r@users.noreply.github.com>2021-02-27 17:13:08 -0500
commit36e32c7c842f5984f59451008c13519989b91bd9 (patch)
tree64f4d54dd4b5289dd1603f9a5154cb706fd67585 /setup.py
parented652a55090e8eaf3e5d715962c9d0715150b3c6 (diff)
downloadwebsocket-client-36e32c7c842f5984f59451008c13519989b91bd9.tar.gz
Replace TravisCI with GitHub Actions
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 9 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index a1c9209..25a3338 100644
--- a/setup.py
+++ b/setup.py
@@ -62,12 +62,14 @@ except Exception:
setup(
name=NAME,
version=VERSION,
- description="WebSocket client for Python. hybi13 is supported.",
- long_description=open("README.rst").read(),
+ description="WebSocket client for Python with low level API options",
+ long_description=open("README.md").read(),
+ long_description_content_type='text/markdown',
author="liris",
author_email="liris.pp@gmail.com",
license="LGPL version 2.1",
url="https://github.com/websocket-client/websocket-client.git",
+ download_url='https://github.com/websocket-client/websocket-client/releases',
python_requires='>=2.6, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
classifiers=[
"Development Status :: 4 - Beta",
@@ -90,7 +92,11 @@ setup(
"Topic :: Software Development :: Libraries :: Python Modules",
"Intended Audience :: Developers",
],
- keywords='websockets',
+ project_urls={
+ 'Documentation': 'https://websocket-client.readthedocs.io/',
+ 'Source': 'https://github.com/websocket-client/websocket-client/',
+ },
+ keywords='websockets client',
scripts=["bin/wsdump.py"],
install_requires=install_requires,
packages=["websocket", "websocket.tests"],