summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorengn33r <engn33r@users.noreply.github.com>2021-02-22 22:06:01 -0500
committerengn33r <engn33r@users.noreply.github.com>2021-02-22 23:18:57 -0500
commit6eaed48d49ea6a1a792b152a477bf9026f0c29b4 (patch)
treec8b5e5831a8c06675653774e2b5897b31c1df4e0 /setup.py
parent833a3df1f956e3eaf8e4dbcddd19b5abd4263958 (diff)
downloadwebsocket-client-6eaed48d49ea6a1a792b152a477bf9026f0c29b4.tar.gz
Fix #526 by reverting invalid BSD license migration in commit e94ed9e to return to LGPL2.1
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py28
1 files changed, 26 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index ddf96d5..a1c9209 100644
--- a/setup.py
+++ b/setup.py
@@ -1,3 +1,27 @@
+"""
+
+"""
+
+"""
+websocket - WebSocket client library for Python
+
+Copyright (C) 2010 Hiroki Ohtani(liris)
+
+ This library is free software; you can redistribute it and/or
+ modify it under the terms of the GNU Lesser General Public
+ License as published by the Free Software Foundation; either
+ version 2.1 of the License, or (at your option) any later version.
+
+ This library is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public
+ License along with this library; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+
+"""
import sys
from setuptools import setup
@@ -42,12 +66,12 @@ setup(
long_description=open("README.rst").read(),
author="liris",
author_email="liris.pp@gmail.com",
- license="BSD",
+ license="LGPL version 2.1",
url="https://github.com/websocket-client/websocket-client.git",
python_requires='>=2.6, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
classifiers=[
"Development Status :: 4 - Beta",
- "License :: OSI Approved :: BSD License",
+ "License :: OSI Approved :: GNU Lesser General Public License v2 or later (LGPLv2+)",
"Programming Language :: Python",
"Programming Language :: Python :: 2",
"Programming Language :: Python :: 2.6",