diff options
-rw-r--r-- | ChangeLog | 12 | ||||
-rw-r--r-- | docs/source/conf.py | 2 | ||||
-rw-r--r-- | setup.py | 2 | ||||
-rw-r--r-- | websocket/__init__.py | 2 |
4 files changed, 15 insertions, 3 deletions
@@ -1,6 +1,18 @@ ChangeLog ============ +- 0.59.0 + + - Last main release to support Python 2 + - Fix Python 2 urlparse scheme (#332) + - Add support for headers with multiple values (#627) + - Add debug support for reserved custom status codes (#639) + - Allow multiple Set-Cookie: headers (#649) + - Simplified cookie sorting (#662) + - Add no_proxy support (#671) + - Add Host header to HTTP proxy request (#677) + - Improve PEP8 style compliance (dc3f5c4) + - 0.58.0 - Fix README typos (#659) diff --git a/docs/source/conf.py b/docs/source/conf.py index 9f44b01..f7f5c57 100644 --- a/docs/source/conf.py +++ b/docs/source/conf.py @@ -34,7 +34,7 @@ copyright = '2021' author = 'liris' # The full version, including alpha/beta/rc tags -release = '0.58.0' +release = '0.59.0' # -- General configuration --------------------------------------------------- @@ -27,7 +27,7 @@ import sys from setuptools import setup import pkg_resources -VERSION = "0.58.0" +VERSION = "0.59.0" install_requires = ["six"] tests_require = [] diff --git a/websocket/__init__.py b/websocket/__init__.py index ce1b787..f2c7b44 100644 --- a/websocket/__init__.py +++ b/websocket/__init__.py @@ -25,4 +25,4 @@ from ._exceptions import * from ._logging import * from ._socket import * -__version__ = "0.58.0" +__version__ = "0.59.0" |