summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Kolbe <jeremykolbe@posteo.net>2018-10-05 09:33:31 +0200
committerGitHub <noreply@github.com>2018-10-05 09:33:31 +0200
commit39f0a23236eded8d771f9c69908fa6d92e2a784f (patch)
treedb6f5765856124dea828af46f6c4650f45fd2d81
parent51bfb4fec11d842c4536cc5d663317fb67590f72 (diff)
downloadzope-event-39f0a23236eded8d771f9c69908fa6d92e2a784f.tar.gz
Add support for Python 3.7 (#12)
-rw-r--r--.travis.yml9
-rw-r--r--CHANGES.rst2
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
4 files changed, 10 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index dcaac77..b7d83f0 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -5,8 +5,13 @@ python:
- 3.4
- 3.5
- 3.6
- - pypy-5.6.0
- - pypy3.3-5.5-alpha
+ - pypy
+ - pypy3
+matrix:
+ include:
+ - python: "3.7"
+ dist: xenial
+ sudo: true
script:
- coverage run -m zope.testrunner --test-path=src
diff --git a/CHANGES.rst b/CHANGES.rst
index b7d4308..d277026 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -5,7 +5,7 @@
4.3.1 (unreleased)
==================
-- Nothing changed yet.
+- Add support for Python 3.7
4.3.0 (2017-07-25)
diff --git a/setup.py b/setup.py
index 6a281af..747895d 100644
--- a/setup.py
+++ b/setup.py
@@ -52,6 +52,7 @@ setup(
"Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: Jython",
"Programming Language :: Python :: Implementation :: PyPy",
diff --git a/tox.ini b/tox.ini
index 0bc7616..a118c23 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,7 +4,7 @@ envlist =
# requests -> html5 libraries. See
# https://github.com/html5lib/html5lib-python/pull/150
# py27,py33,py34,pypy,pypy3,jython,coverage,docs
- py27,py34,py35,py36,pypy,pypy3,coverage,docs
+ py27,py34,py35,py36,py37,pypy,pypy3,coverage,docs
[testenv]
commands =