summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Gedminas <marius@gedmin.as>2020-04-10 13:03:04 +0300
committerMarius Gedminas <marius@gedmin.as>2020-04-10 13:04:59 +0300
commit806013570797583d6c3d724e975b969138806c08 (patch)
treec0b260ba405f2930bd859cbb3493cb8f8bae29b6
parent085df868bb797ebf05a6327548c05b23c76bed4b (diff)
downloadzope-exceptions-py38.tar.gz
Add Python 3.8, drop 3.4.py38
-rw-r--r--.travis.yml9
-rw-r--r--CHANGES.rst4
-rw-r--r--setup.py6
-rw-r--r--tox.ini2
4 files changed, 9 insertions, 12 deletions
diff --git a/.travis.yml b/.travis.yml
index 2826f59..9cfc6f8 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,16 +1,11 @@
language: python
-sudo: false
python:
- 2.7
- - 3.4
- 3.5
- 3.6
+ - 3.7
+ - 3.8
- pypy
-matrix:
- include:
- - python: "3.7"
- dist: xenial
- sudo: true
install:
- pip install -U pip setuptools
- pip install -U coverage coveralls
diff --git a/CHANGES.rst b/CHANGES.rst
index def981c..9246e3d 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -5,7 +5,9 @@
4.4 (unreleased)
================
-- Nothing changed yet.
+- Add support for Python 3.8.
+
+- Drop support for Python 3.4.
4.3 (2018-10-04)
diff --git a/setup.py b/setup.py
index 76565a6..47e4f94 100644
--- a/setup.py
+++ b/setup.py
@@ -61,12 +61,12 @@ setup(name='zope.exceptions',
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
- "Programming Language :: Python :: Implementation :: CPython",
- "Programming Language :: Python :: Implementation :: PyPy",
+ 'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
'Operating System :: OS Independent',
'Topic :: Internet :: WWW/HTTP',
diff --git a/tox.ini b/tox.ini
index 58762f4..071807e 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py27,py34,py35,py36,py37,pypy,pypy3,coverage,docs
+ py27,py35,py36,py37,py38,pypy,pypy3,coverage,docs
[testenv]
commands =