summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaurits van Rees <maurits@vanrees.org>2022-11-08 12:10:51 +0100
committerMaurits van Rees <maurits@vanrees.org>2022-11-08 12:10:51 +0100
commit0beb5834325358315f8e33dccaff911ee586d21d (patch)
treeaa30235f7e5256e6e6abe426defbb57254c16ce6
parent9b1b180deab42116d7b8f9ea9f73ecc180b639e9 (diff)
downloadzope-exceptions-0beb5834325358315f8e33dccaff911ee586d21d.tar.gz
Configuring for pure-python
-rw-r--r--.github/workflows/tests.yml6
-rw-r--r--.gitignore1
-rw-r--r--.meta.toml2
-rw-r--r--setup.cfg11
-rw-r--r--tox.ini19
5 files changed, 32 insertions, 7 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index d31f648..932104c 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -28,12 +28,14 @@ jobs:
- ["3.8", "py38"]
- ["3.9", "py39"]
- ["3.10", "py310"]
- - ["pypy2", "pypy"]
- - ["pypy3", "pypy3"]
+ - ["3.11", "py311"]
+ - ["pypy-2.7", "pypy"]
+ - ["pypy-3.7", "pypy3"]
- ["3.9", "docs"]
- ["3.9", "coverage"]
runs-on: ${{ matrix.os }}-latest
+ if: github.event_name != 'pull_request' || github.event.pull_request.head.repo.full_name != github.event.pull_request.base.repo.full_name
name: ${{ matrix.config[1] }}
steps:
- uses: actions/checkout@v2
diff --git a/.gitignore b/.gitignore
index c724a76..1f321f5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -28,4 +28,5 @@ lib64
log/
parts/
pyvenv.cfg
+testing.log
var/
diff --git a/.meta.toml b/.meta.toml
index aa2e6d7..bacd0f1 100644
--- a/.meta.toml
+++ b/.meta.toml
@@ -2,7 +2,7 @@
# https://github.com/zopefoundation/meta/tree/master/config/pure-python
[meta]
template = "pure-python"
-commit-id = "121e74bd9c9718abd9a1a079e6ede252c1a0ba7d"
+commit-id = "b4dd6f9ffd3d6a2cde7dc70512c62d4c7ed22cd6"
[python]
with-pypy = true
diff --git a/setup.cfg b/setup.cfg
index 8b04203..124476d 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -12,3 +12,14 @@ ignore =
.meta.toml
docs/_build/html/_sources/*
docs/_build/doctest/*
+
+[isort]
+force_single_line = True
+combine_as_imports = True
+sections = FUTURE,STDLIB,THIRDPARTY,ZOPE,FIRSTPARTY,LOCALFOLDER
+known_third_party = six, docutils, pkg_resources
+known_zope =
+known_first_party =
+default_section = ZOPE
+line_length = 79
+lines_after_imports = 2
diff --git a/tox.ini b/tox.ini
index 1e36bad..a29d4ba 100644
--- a/tox.ini
+++ b/tox.ini
@@ -11,6 +11,7 @@ envlist =
py38
py39
py310
+ py311
pypy
pypy3
docs
@@ -29,15 +30,25 @@ extras =
[testenv:lint]
basepython = python3
skip_install = true
+commands =
+ isort --check-only --diff {toxinidir}/src {toxinidir}/setup.py
+ flake8 src setup.py
+ check-manifest
+ check-python-versions
deps =
- flake8
check-manifest
check-python-versions >= 0.19.1
wheel
+ flake8
+ isort
+
+[testenv:isort-apply]
+basepython = python3
+commands_pre =
+deps =
+ isort
commands =
- flake8 src setup.py
- check-manifest
- check-python-versions
+ isort {toxinidir}/src {toxinidir}/setup.py []
[testenv:docs]
basepython = python3