summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Gedminas <marius@gedmin.as>2020-04-10 19:26:27 +0300
committerMarius Gedminas <marius@gedmin.as>2020-04-10 19:26:27 +0300
commitb6b992059541a9f3c559ebbe67d70f3041129790 (patch)
treecf1c9b726e1f1dac1a7962af52c11565aa1ba9fe
parentbfa427e05da8e4505c32aefbae311775aca76db0 (diff)
downloadzope-exceptions-b6b992059541a9f3c559ebbe67d70f3041129790.tar.gz
Make the flake8 job use a separate cache
The CACHE_NAME environment variable hack is recommended by https://docs.travis-ci.com/user/caching/ Also, AFAIU the before_cache: rm pip/debug.log is needed only if you manually try to cache the ~/.cache/pip directory, and shouldn't be needed for cache: pip. Also I like 2-space indents in YAML files so there.
-rw-r--r--.travis.yml27
1 files changed, 13 insertions, 14 deletions
diff --git a/.travis.yml b/.travis.yml
index fb98a36..731fbc3 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,28 +1,27 @@
language: python
python:
- - 2.7
- - 3.5
- - 3.6
- - 3.7
- - 3.8
- - pypy
+ - 2.7
+ - 3.5
+ - 3.6
+ - 3.7
+ - 3.8
+ - pypy
jobs:
include:
- name: flake8
install: pip install flake8
script: flake8 src setup.py
after_success:
+ env: CACHE_NAME=flake8
install:
- - pip install -U pip setuptools
- - pip install -U coverage coveralls
- - pip install -U -e .[test,docs]
+ - pip install -U pip setuptools
+ - pip install -U coverage coveralls
+ - pip install -U -e .[test,docs]
script:
- - coverage run -m zope.testrunner --test-path=src
- - coverage run -a -m sphinx -b doctest -d docs/_build/doctrees docs docs/_build/doctest
+ - coverage run -m zope.testrunner --test-path=src
+ - coverage run -a -m sphinx -b doctest -d docs/_build/doctrees docs docs/_build/doctest
notifications:
- email: false
+ email: false
cache: pip
-before_cache:
- - rm -f $HOME/.cache/pip/log/debug.log
after_success:
- coveralls