summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Yan <felixonmars@archlinux.org>2015-11-07 22:28:42 +0800
committerFelix Yan <felixonmars@archlinux.org>2015-11-07 22:28:42 +0800
commit99adf174f40e2ee67e4f900351309ab35b04a412 (patch)
tree949378fc68ddaa34e26e2176397f710ad2c0c07c
parent3bcdfdcda8d85a0b5383ab529fdb6fb789c7e3ef (diff)
downloadzope-location-99adf174f40e2ee67e4f900351309ab35b04a412.tar.gz
Note explicit support for Python 3.5
-rw-r--r--.travis.yml5
-rw-r--r--CHANGES.rst2
-rw-r--r--README.rst2
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
5 files changed, 9 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
index 67f915e..f7501ad 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -5,9 +5,12 @@ python:
- 2.7
- 3.2
- 3.3
+ - 3.4
+ - 3.5
- pypy
+ - pypy3
install:
- - pip install . --use-mirrors
+ - pip install .
script:
- python setup.py test -q
notifications:
diff --git a/CHANGES.rst b/CHANGES.rst
index 6b6a182..c98bd89 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -8,6 +8,8 @@ Changes
- Note additional documentation dependencies.
+- Claim support for Python 3.5.
+
4.0.3 (2014-03-19)
------------------
diff --git a/README.rst b/README.rst
index bf8f478..1dcb61a 100644
--- a/README.rst
+++ b/README.rst
@@ -1,7 +1,7 @@
``zope.location``
=================
-.. image:: https://pypip.in/version/zope.location/badge.svg?style=flat
+.. image:: https://img.shields.io/pypi/v/zope.location.svg
:target: https://pypi.python.org/pypi/zope.location/
:alt: Latest Version
diff --git a/setup.py b/setup.py
index 9675429..c4669ed 100644
--- a/setup.py
+++ b/setup.py
@@ -50,6 +50,7 @@ setup(name='zope.location',
'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
diff --git a/tox.ini b/tox.ini
index b8c605e..a9f684e 100644
--- a/tox.ini
+++ b/tox.ini
@@ -3,7 +3,7 @@ envlist =
# Jython support pending 2.7 support, due 2012-07-15 or so. See:
# http://fwierzbicki.blogspot.com/2012/03/adconion-to-fund-jython-27.html
# py26,py27,py32,jython,pypy,coverage
- py26,py27,py32,py33,py34,pypy,coverage,docs
+ py26,py27,py32,py33,py34,py35,pypy,pypy3,coverage,docs
[testenv]
commands =