summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Howitz <mh@gocept.com>2022-12-15 08:16:14 +0100
committerGitHub <noreply@github.com>2022-12-15 08:16:14 +0100
commit2408ce78ca89c8076a0b97528636e44514b2c81c (patch)
tree4502d2a5111d3746e8d1d6c46e1177788e1e9126
parent6b4d37420184e8712f8e72484555f9545f85cd42 (diff)
downloadzope-schema-2408ce78ca89c8076a0b97528636e44514b2c81c.tar.gz
Fix GHA: ubuntu-latest no longer contains Python 3.5 and 3.6 (#117)
Add support for Python 3.11.
-rw-r--r--.github/workflows/tests.yml11
-rw-r--r--.meta.toml3
-rw-r--r--CHANGES.rst2
-rw-r--r--setup.py1
-rw-r--r--tox.ini6
5 files changed, 15 insertions, 8 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index f9f622d..cedf24b 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -17,7 +17,7 @@ jobs:
fail-fast: false
matrix:
os:
- - ubuntu
+ - ["ubuntu", "ubuntu-20.04"]
config:
# [Python version, tox env]
- ["3.9", "lint"]
@@ -28,22 +28,23 @@ jobs:
- ["3.8", "py38"]
- ["3.9", "py39"]
- ["3.10", "py310"]
+ - ["3.11", "py311"]
- ["pypy-2.7", "pypy"]
- ["pypy-3.7", "pypy3"]
- ["3.9", "docs"]
- ["3.9", "coverage"]
- runs-on: ${{ matrix.os }}-latest
+ runs-on: ${{ matrix.os[1] }}
if: github.event_name != 'pull_request' || github.event.pull_request.head.repo.full_name != github.event.pull_request.base.repo.full_name
name: ${{ matrix.config[1] }}
steps:
- - uses: actions/checkout@v2
+ - uses: actions/checkout@v3
- name: Set up Python
- uses: actions/setup-python@v2
+ uses: actions/setup-python@v4
with:
python-version: ${{ matrix.config[0] }}
- name: Pip cache
- uses: actions/cache@v2
+ uses: actions/cache@v3
with:
path: ~/.cache/pip
key: ${{ runner.os }}-pip-${{ matrix.config[0] }}-${{ hashFiles('setup.*', 'tox.ini') }}
diff --git a/.meta.toml b/.meta.toml
index 2e9b52d..e6e881b 100644
--- a/.meta.toml
+++ b/.meta.toml
@@ -2,7 +2,7 @@
# https://github.com/zopefoundation/meta/tree/master/config/pure-python
[meta]
template = "pure-python"
-commit-id = "ae61f414cfef4e129d275679c6a76dc67b1a2c11"
+commit-id = "200573eb414d2228d463da3de7d71a6d6335a704"
[python]
with-pypy = true
@@ -11,6 +11,7 @@ with-docs = true
with-sphinx-doctests = true
with-windows = false
with-future-python = false
+with-macos = false
[coverage]
fail-under = 100
diff --git a/CHANGES.rst b/CHANGES.rst
index 2fc9c3c..1ee32f4 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -6,6 +6,8 @@
==================
+- Add support for Python 3.11.
+
6.2.1 (2022-09-14)
==================
diff --git a/setup.py b/setup.py
index 0256e1c..19f84b8 100644
--- a/setup.py
+++ b/setup.py
@@ -72,6 +72,7 @@ setup(
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
"Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
"Framework :: Zope :: 3",
diff --git a/tox.ini b/tox.ini
index 5addfe0..37ee92a 100644
--- a/tox.ini
+++ b/tox.ini
@@ -11,6 +11,7 @@ envlist =
py38
py39
py310
+ py311
pypy
pypy3
docs
@@ -43,6 +44,7 @@ deps =
[testenv:isort-apply]
basepython = python3
+skip_install = true
commands_pre =
deps =
isort
@@ -68,8 +70,8 @@ commands =
mkdir -p {toxinidir}/parts/htmlcov
coverage run -m zope.testrunner --test-path=src {posargs:-vc}
coverage run -a -m sphinx -b doctest -d {envdir}/.cache/doctrees docs {envdir}/.cache/doctest
- coverage html
- coverage report -m --fail-under=100
+ coverage html --ignore-errors
+ coverage report --ignore-errors --show-missing --fail-under=100
[coverage:run]
branch = True