diff options
author | Nate Prewitt <Nate.Prewitt@gmail.com> | 2018-06-10 14:45:14 -0700 |
---|---|---|
committer | Nate Prewitt <Nate.Prewitt@gmail.com> | 2018-06-10 14:49:13 -0700 |
commit | de64f0f23f57f272ed11713d18ff50f193c3164b (patch) | |
tree | 94b40be3eec0a22fb5a5dc73bdabc79b9ac82168 /setup.py | |
parent | bc46de58e61149879fea0cf51399c5dd63dbb227 (diff) | |
download | python-requests-de64f0f23f57f272ed11713d18ff50f193c3164b.tar.gz |
port pyopenssl fix from urllib3
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 8 |
1 files changed, 7 insertions, 1 deletions
@@ -40,6 +40,12 @@ if sys.argv[-1] == 'publish': os.system('twine upload dist/*') sys.exit() +# pyOpenSSL version 18.0.0 dropped support for Python 2.6 +if sys.version_info < (2, 7): + PYOPENSSL_VERSION = 'pyOpenSSL >= 0.14, < 18.0.0' +else: + PYOPENSSL_VERSION = 'pyOpenSSL >= 0.14' + packages = ['requests'] requires = [ @@ -96,7 +102,7 @@ setup( cmdclass={'test': PyTest}, tests_require=test_requirements, extras_require={ - 'security': ['pyOpenSSL>=0.14', 'cryptography>=1.3.4', 'idna>=2.0.0'], + 'security': [PYOPENSSL_VERSION, 'cryptography>=1.3.4', 'idna>=2.0.0'], 'socks': ['PySocks>=1.5.6, !=1.5.7'], 'socks:sys_platform == "win32" and (python_version == "2.7" or python_version == "2.6")': ['win_inet_pton'], }, |