summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorKenneth Reitz <me@kennethreitz.org>2017-05-28 12:14:27 -0400
committerKenneth Reitz <me@kennethreitz.org>2017-05-28 12:14:27 -0400
commite6e3589c36181ae952493ae3ff37f21a450110aa (patch)
treed098bf8e085d534f9cd5b5f0d9f4180336bcdd89 /setup.py
parentc3a00771e395789b4704a7e8a01d01acb04dcde2 (diff)
downloadpython-requests-e6e3589c36181ae952493ae3ff37f21a450110aa.tar.gz
number of cores for travis
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index a316402e..193c8877 100755
--- a/setup.py
+++ b/setup.py
@@ -8,6 +8,7 @@ from codecs import open
from setuptools import setup
from setuptools.command.test import test as TestCommand
+from multiprocessing import cpu_count
here = os.path.abspath(os.path.dirname(__file__))
@@ -16,7 +17,7 @@ class PyTest(TestCommand):
def initialize_options(self):
TestCommand.initialize_options(self)
- self.pytest_args = ['-n', '8', '--boxed']
+ self.pytest_args = ['-n', str(cpu_count()), '--boxed']
def finalize_options(self):
TestCommand.finalize_options(self)